We help IT Professionals succeed at work.

Windows 2000 AD DC  - My Second DC is down and will not boot. Error is INACCESSIBLE BOOT DEVICE  What do I need to do to fix it?

I have two identical Windows 2000 Boxes both Dell PE 1600SC Servers.  My problem is I need to migrate to Windows 2008 R2 AD-DC but my 2nd Domain Controller is down and I do not want to change my only DC until I get this second one back up. I know nothing should happen when updating the only AD-DC but if something does I am s.o.l.

I have 3 total 1600SCs one is a file server (2 are AD-DC all with win 2000 standard server with sp4) and for the past 4-5 years I have always had problems rebooting. Whenever you reboot any one of the 1600SCs they boot to a black window with a blinking cursor and you have to manually reset the server (they all do it) and it will boot then the log in prompt eventually appears and all is well. I posted this question years ago but never got a real answer, not even from Dell. They wanted me to format but since 2 of the 3 were AD-DCs I couldn't do it.

RE: The 2nd AD-DC:
When booting I get to the Loading windows with a progress bar (Windows 2000 Server Standard with SP4) then I get the BSOD with "Inaccessible Boot Device Error" with a SCSI Drive that has failed (that is my guess). It was using a software mirror from within Windows 2000 the original Drive Failed years ago and I added a new 2nd Drive but it will not boot off of it (so I don't know if there is any data on it at all) or if the  SCSI Controller is failing.  If I unplug the SCSI from the main drive I get no OS Found on the other SCSI drive. The controller settings screen sees the other drive but I cannot choose which to boot off it is greyed out (controller came with the server)
 
I "may" have a system state backup that is a couple of months old.  Is there anything I can to do get this Server up and running so I can migrate over to Windows 2008 R2 AD-DC running DNS?

I do not know what I need to do with the System State backup that I may have. Are there easy/hand-holding/step-by-step walk-throughs on restoring the system state (if that is what is needed)?

I cannot boot in to safe mode either, same problem, gets to a point and same error.

I can try booting in to command prompt via System Restore option (R) when booting from Windows 2000 SP4 Disc and run the check disk command. I have not done this yet. Or can I use the working DC and create an Emergency Restore disk?  I did have one but it will not read it. Disk is very old.  

I may have a full image from Acronis True Image Echo Server but the drives are set as Dynamic (due to it being a software raid 1 in Windows) and I do not think it will restore a dynamic drive. I am not 100% it is a full backup it may be a system state as well. I will need to look at the internal hidden drive (IDE).

If I I have a full backup can I restore to an IDE drive that I have laying around?  I will just have to change the boot order in the BIOS correct? or is there something else I need to change as well?

If I cannot get the System State or Full Backup in my hands what is the best solution to fix the inaccessible boot device error?  Run Check Disk like I mentioned earlier? Or is there an alternative? and if Check Disk runs but does not fix the problem, then what?

---

IF I can get the System State back up (if its a few months old) and get in to a working windows environment, will the One and only AD-DC update  all of the old information to "catch it up" with current data?

I am just trying to find a quick and easy solution to get the 2nd AD-DC up and running so I can then move over to a Windows 2008 R2 AD-DC with DNS (two physical servers and may setup a 3rd Virtual one).

Thanks for any help and sorry for the long post.
Comment
Watch Question

Commented:
You've got nothing to lose by running the CHKDSK from the recovery console.

The hardware you're running is fairly dated, and since they are older than 5 years old, I'm not surprised Dell hasn't provided any support.  Instead of trying to recover the old 2nd DC, you may want to replace the server completely (new hardware), install Server 2008 and configure AD.  Once you've got the directory synced, shut down the Win 2000 AD-DC, and run DCPROMO on the 2008 server.  If anything goes bad, you still have the option of reverting back to your old DC.

Author

Commented:
Thank you for the reply:

Well it was still under warranty at that time. Any way doesn't matter, once we move to the new hardware the old ones are going away.

I will try the CHKDSK, thanks

Re: Windows 2008, do I use R2 or just Windows 2008? Does it matter if it is x32 or x64?
Also, if I Configure AD on the Windows 2008 Server (which is already up and running, just a member right now).  Don't I have to run a command on the old Windows 2000 box prior to running Windows 2008 along side it?  Isn't there a totally different schema? or I am thinking of something else?  

Author

Commented:
I know R2 is only x64 so sorry about that but is that what you were referring to or just "Windows 2008 Standard (x32 or x64 or does it matter)?

Also, the command I was referring to is something on the Windows 2008 DVD called ADPREP. That is what I am not excited to run on the Windows 2000 Server because I don't want to mess it up.

However, if all I have to do is configure AD on Windows 2008  and let them sync then I am fine with that. I have 3 Windows 2008 Servers (ready to have AD configured).  2 have Windows Server 2008 R2 Standard  (x64) and the other has Windows Server 2008 Standard with SP2 (x32)

Commented:
Definitely go Windows Server 2008 R2.

Unfortunately, I haven't had to promote a member controller to primary controller myself, so I can't give you any first-hand guidance.  Instead, I'll refer you to the TechNet article:  http://technet.microsoft.com/en-us/library/upgrade-domain-controllers-to-windows-server-2008-r2%28WS.10%29.aspx

Author

Commented:
Thanks I think I have that link in another open question.
Will try the chkdsk on this old server, can't hurt I guess.

Commented:
parmor
I need a little bit more info on the SCSI drive issue to understand your problem.
Am I correct in saying that you can not boot from either of the two SCSI drives as a single drive on your 2nd AD-DC? If that is the case the problem started when you added a new 2nd drive years ago as the original W2kSVR mirror was probably not correctly "broken" and once the 2nd drive was fitted the mirrow was corrupted. This could have lead to your swap file ending up on one drive and the rest of the OS on the other and would explain why you must have both drives in place. In that case their positions are also vital and would explain why you are not able to swop them over.
The system state back up will probably not help you then. If my assuptions are correct I will try to help you with a step-by-step walk-through but it is not easy.
If the SCSI controller was failing you should be able to see that as a System Event after a boot in the MMC (Microsoft Management Console)
I asume that chkdsk on the drives will be fine.
If any of my assumtions are correct and you have the W2kSVR CD remove the SCSI drives from the machine set up the IDE and install the W2kSVR os on that drive. Make sure the PC boots from that drive then let me know and we can diagnose the problem further.

Author

Commented:
Thanks Gudufl.

Kind of sort of :)
The original Primary Drive Failed 8-9 months ago.  I broke the mirror and was only using one drive.  Then I added a 2nd Drive 6 months ago and I could have sworn it was setup to mirror the only working drive. I could be wrong.

Currently, I am spending a lot of my time trying to find the Windows 2000 Server CD that came with the Dell.  I stored it in a safe place that is no longer save in my head. It has been many years since needing it. I was hoping to download the MSDN version but they no longer have it there because of an issue with distributing Java (lawsuit iirc).  So I need it first.
Thanks for your help.
Commented:
As you say you manage to boot from the secondary mirror on its own after you broke the mirror when the primary drive failed 8-9 month ago before you added the 2nd drive 6month ago, try to boot with both SCSI drives in place. Go to MMC and break the mirror. Remove the secondary mirror and try to boot from the primary mirror. Let me know what happens.

Has the PC got a working stiffy drive?

Author

Commented:
I have both SCSI drives still in place but I cannot boot in to windows, I get the BSOD
I do have  a floppy drive. I assume it works its been awhile as well.
I cannot boot in to windows at all either normal mode or safe mode.

Commented:
Lets give these baybies a name call the primary mirror drive1 and the secondary mirror drive2.
Remove drive2 compleetly make sure power cord is also disconnected boot from drive,  then do the same for drive2. Please give me all the info on the drive lable, that we can check what jumpers might have to be changed to run and test the drives as single boot drives if you are not 100% sure otherwise ignore. Let me know what happens.

Forget the safe mode for now.
Have you got a stiffy disk 1.44MB?  I asume that you have one of those drives not a floppy drive!
We might need a bootable DOS6.22 stiffy disk and a copy of Ghost7.5.

Author

Commented:
I do have a disk yes for the floppy drive. also have the 4 floppy disks that were created (emergency repair disks?)

Will do that with drives and give you the info.

I even have a 3rd scsi but it does not get recoginzed by the controller any time, even when no other device is connected. so I am not going to mess with it.
I purchased them (the two replacement drives at the same time, used one and kept the 3rd as a spare).

Commented:
The 4disks created during the W2kSVR installation are EBD (emergency boot disks) and will not boot the PC to a DOS Command promt. The ERD (emergency repair disk) is a single disk that can be created from a working W2k and W2kSVR OS. I hope that the PC with the working W2kSVR OS has a stiffy drive. Then you would be able to create a ERD. I will need to check if Ghost7.5 will run once the PC is booted from the ERD.

Where those new drives that you purchased?  

Author

Commented:
no they were refurbs
I am looking for the scsi controller driver.  I have tried all by dell (F6 option) prior to getting to the recovery  console to no avail.

Commented:
Ok then no piont in persuing a dead avenue.
Please use the "working DC" to create a ERD.
Start>Programs>Accessories>System Tools>Backup
Insert the stiffy in Drive A:\
Once Backup is open >Tools>Create an Emergency Repair Disk and follow the promps.
Test the disk by booting the "faulty DC" from the just created disk.
Make notes of screen messages and post them here.

Author

Commented:
Sorry was working on it last night. This is what I did (before seeing your message)

I have a 320GB IDE/PATA drive as a secondary slave (primary is CDROM) that is an Acronis TI Echo Server "securezone" (hidden) that does three full backups a week.

So, I disconnected all SCSI drives/power/cables and installed a new 250 GB IDE drive as master. I booted in to Acronis TI boot system and completely formatted new drive. My last full backup was a month ago (since the server went down).
I restored all partitions, MBR, C: and D: (all were one same physical scsi).
Booted, logged in as just fine. OS apparently. Noticed IDE and asked to reboot for new devices to work. At the restart the same stupid black screen with blinking cursor. Same as the other two working PE1600SCs (this one did it before as well).
Pushed reset, logged in to windows all ok.  Next step add a mirrored IDE drive (software/windows)

Rebooted BSBWC (black screen blinking white cursor). Pushed power. Plugged in 2nd new 250gb IDE (slave) booted to Acronis. Formatted drive. Rebooted. Logged in to windows. Found IDE had to reboot. BSBWC pushed reset (lol)

Logged in to windows changed drives from basic to dynamic.
Rebooted, BSBWC pushed reset. Logged in to windows.
Created Mirror of all partitions but did not see mbr partition (but looked like it was part of C:)
Message said need to add proper entry to boot.ini
Creating mirror.

Phew:
1) Can you remind me what I need to enter in the boot.ini to boot off slave if problem?

2) how the heck do I fix this, BSBWC push reset, on all 3 Dell PE1600SCs?

Thanks

Commented:
Now you have lost me a little but from your last post I would say that you are doing to many things at once. You should leave the changing from basic to dynamic and the mirror until you have one drive that boots the way it should without the BSBWC. It appears to me that you are resoring from a full backup that already had the BSBWC issue.
I am not following you were you refer to the new 250GB IDE drive with the restored partition, when you say: "Booted, logged in as just fine. OS apparently." What actualy happened?
You did not check where your swap file is positioned before reboot when you where asked to reboot for new devices to work!
As you have a new 250GB IDE that you can use as a master and I am hoping that you have found the Windows 2000 Server CD that came with your machine you should create a fresh installation of the OS on that drive. This would bring to light any other issues with the machine. If the installation runs smothly you would have a platform from which to further diagnose the issues with the SCSI drive/s.
You can not hope to fix the problems you are experiancing if you do not work systematicaly.
 

Author

Commented:
I could not get the recovery console to recognize my SCSI 0 drive because when I loaded the win 2000 cd I had to load drivers for SCSI controller (push F6). Every driver (on floppy disk drive) offered by dell would not work. Windows would say "no hardware found using the supplied driver"(paraphrasing).

I have a "hidden drive" (called Secure Zone made by Acronis on a 320gb ide drive) plugged in to Secondary Slave IDE that Acronis True Image Echo Server (like Symantec Ghost) that made full backups of the server three times a week. The latest backup was from Nov 6 (server drive went down after November 6th but before 9th based on the backups).

Since I could not use any SCSI drives because Windows did not recognize drivers I used a new 250GB IDE in the primary master IDE plug. I restored the full backup from Acronis TI (Nov 6) and it worked just fine. Windows was running again.

The new IDE was a "Basic" drive after the restore and I still had the BSBWC issue when I restarted. Since it was still there it was obviously not a "Basic-Dynamic Drive" issue I continued on.

I then added a second 250GB IDE as primary slave IDE and in windows disc management, I created a mirror.

That is why I posted the followup two questions. I was back up and running on different hard drives.
Commented:
Parmor, sorry for only comming back to you now. We had INet connection issues in the last couple of days. This is something that happens from time to time in the remote rural area I opperate from.

To question 1.
The boot.ini file should look like this:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Server" /fastdetect
Also refer to:
   WinNT: http://support.microsoft.com/kb/102873
   W2kSvr For additional information about ARC names in the Boot.ini file,
     http://support.microsoft.com/kb/227704/vi-v
   W2kSvr Available switch options for the Windows 2000 Boot.ini
     http://support.microsoft.com/kb/833722/zh-t
   W2kSvr Booting From Mirror After Primary Partition Is Lost
     http://support.microsoft.com/kb/113977
   MSKB302969_How To Mirror the System and Boot Partition (RAID1) in Windows 2000
     http://support.microsoft.com/kb/302969

To question 2.
Please let me know what the path to the swap file is.
Open MMC (RClick "My Computer>Manage)
RClick>Computer Management (Local)>Properties>Advanced>Performance Options>Change
Screen capture or make notes of all the info on the Virtual Memory page and post.
Also run regedit or regedt32 then,
Check the data at: HKEY_USERS\.Default\Control Panel\Colors and post the info.

As long as the BSBWC issue is their the mirror is of little use exept as a backup. Break the mirror and revert the primary drive to a Basic Disk and only work with that drive until that issue is resolved. The mirror you are going to remove is a backup already which is good practice.
I will only be in touch again on Monday 2011-12-19    

Commented:
Parmor,
Have you resolved the issues?

Author

Commented:
Sorry, holidays and other stuff coming up. Will look at those. again, thanks and sorry for the delay.

Commented:
No problem. Hope u had a good season and landed well in 2012.

Author

Commented:
thanks for the help and sorry it took so long. It is backup and running.