We help IT Professionals succeed at work.

Xcopy Multiple Errors

RfromP
RfromP asked
on
Hello,

I'm am trying to upgrade the firmware of my printer at work over the network.

My system is Vista SP2.
The printer is a HP Color LaserJet 3500.

I've downloaded the .rfu file from HP.

I right-click the Command Prompt and Run as Administrator.

I've tried several variations of Xcopy syntax and received several different errors.

For simplicity I've moved the .rfu file to a directory on the c: drive.

In the readme file from HP it says to use:

copy /b FILENAME \\SHARENAME\PRINTERNAME

I get invalid syntax error on that one.

I've tried: xcopy /b FILENAME "c:\FOLDERNAME\SUBFOLDERNAME\" \\SHARENAME\PRINTERNAME

I get invalid number of paramenters error.

I've tried: copy FILENAME "c:\FOLDERNAME\SUBFOLDERNAME" \\SHARENAME\PRINTERNAME

I get The system cannot find the file specified.


I've scoured the internet for syntax examples but I've yet to find the correct way to do what I want to do. Thanks in advance for any help you can provide.
Comment
Watch Question

Since you're using Vista, I would try using robo copy instead.  xcopy is deprecation.  are you able to get to and shared folders on the printer.  There may be an even easier way to upgrade the firmware.  Most printers have a GUI you can use to upload.
So for testing purposes this is what I would try from with the command prompt navigate to the folder where the .rfu file is. For example if the the file was located in a folder on the the local C drive called 'Test'  You can accomplish this at the command prompt by running C:>cd\test

that should put you at the command prompt C:>test

Then type: xcopy /b Filename \\sharename\printername

Commented:
Also, if either the filename or the \\sharename\printername include spaces, you'll need to enclose them in double quotes:

xcopy /b "firmware update.rfu" "\\ourserver\pr printer"

Author

Commented:
Hi Patmac951,

I've navigated into the directory in MS-DOS where the file is located and did a "dir" and it lists the file.

I then tried:

xcopy /b FILENAME \\COMPUTERNAME\PRINTERNAME

It tells me "Invalid number of parameters"

I did something wrong I suppose. :(

Author

Commented:
Hi SuperTaco,

That makes sense to use robocopy, I'd like to try that.

In reference to your question, I'm not sure how to get to the shared folders on the printer.

I've also looked at the GUI through IE but strangely there is not option to update the firmware.

Can you give me an example of the robocopy syntax that you would try?

Thanks.

Commented:
Sounds like spaces.  What is the actual command you are typing?
Can you supply me the exact file name  you are trying to copy along with the full printer share path?  \\computername\printer  

In case you might be experiencing DNS issues on your network you can try replacing the \\computername with the IP address of the computer where the printer is installed.

Author

Commented:
Hi ubound,

From the directory the file is located, I typed:

xcopy /b FILENAME \\COMPUTERNAME\PRINTERNAME

I got "Invalid number of parameters"

Commented:
?

You mean you are literally typing the word FILENAME?  You are supposed to replace that with the name of the file you downloaded.  Presumably something that ends with .rfu.

Also, you shouldn't literally be typing \\COMPUTERNAME\PRINTERNAME.  You should replace this with the server + printername of your network printer.

If I misunderstood you and you are replacing these with the real values, what is the exact actual command you are typing?
Hey RfromP,

I would really like to help you with this problem but unless you supply me exact details it is going to be difficult.  Can you please post the exact (verbatim) to the letter command you are trying to run......do not provide examples like filename....just post the exact syntax of the xcopy command you are trying to run.

Author

Commented:
Patmac951,

The filename is:

clj3500fw_1_000_4.rfu

Here's a little added info.

The printer wasn't shared, I had to share it. The share name that is showing up in the directory is:

\\MYCOMPUTERNAME\PRINTERNAME

and that's what I've been using when trying to make the copy.

I've tried two things:

\\MYCOMPUTERNAME\PRINTERIP

\\MYCOMPUTERIP\PRINTERIP

and it seemed like it was going to work but then gave me the error, "Invalid drive specification" both times.

Author

Commented:
ubound & Patmac951,

lol, no I'm not literally tying COMPUTERNAME, FILENAME, or PRINTERNAME. I'm typing the specific names.

Here's exactly what I'm typing from the directory in which the file is located:

xcopy /b clj3500fw_1_000_4.rfu \\dalwksh3ae212\HP Color LaserJet 3500

"Invalid parameters"

Commented:
Ahh.  As I said before: Spaces.

Try this:

xcopy /b clj3500fw_1_000_4.rfu "\\dalwksh3ae212\HP Color LaserJet 3500"
Ok to avoid confusion. First rename clj3500fw_1_000_4.rfu to something like clj3500.rfu to just simplfy the name and remove the underscores.

Secondly I am not a hacker can you supply with the exact names, for example \\mycomputername\printername with the the actual names....what exactly are the names of all devices??

Finally what exact directory is the file in?

To avoid confusion, after you rename the file simply create a folder on the root of the local drive called "Test"  do not put in the quotes, just TEST.  Copy the renamed file to the folder c:\test

At a command prompt type c:>cd\test

So the prompt should look like this: c:test>

xcopy clj3500.rfu /b \\computerip\printername

So for example if the computer IP address was 192.168.1.10 and the printer name was HP3500

The exact command would be:

xcopy clj3500.rfu /b \\192.168.1.10\hp3500

Author

Commented:
ubound,

I did exactly what you said and it copied the file.

Funny thing is that it created a folder on my c: drive named DALWKSH3AE212 and in that folder is another folder called HP Color Laserjet 3500 and in that folder is the file I copied. It had no effect on the printer so it seems it didn't make it to the printer.
Like Ubound suggested because of the underscores and spaces it run the command like this rename the .RFU file to something simple like clj3500.rfu then from the command prompt, in the directory where the file is located type this command

xcopy /b clj3500.rfu "\\dalwksh3ae212\HP Color LaserJet 3500"




Ok try this then:

xcopy /b clj3500.rfu \\dalwksh3ae212\PrinterIP

No quotes
If that does not work then just try the copy command

Ok try this then:

copy /b clj3500.rfu \\dalwksh3ae212\PrinterIP

No quotes

Author

Commented:
Patmac951,

I did exactly what you said, substituting with the relevant IP and printer names, and got:

"Invalid drive specification"

Author

Commented:
Patmac951,

I tried (substituting the relevant printer IP):

xcopy /b clj3500.rfu \\dalwksh3ae212\PrinterIP

and got "Invalid drive specification"



I tried (substituting the relevant printer IP):

copy /b clj3500.rfu \\dalwksh3ae212\PrinterIP

and I got "The network path was not found"
Ok do you know the IP address of the printer?

Once logged into the local network where the printer is installed open up a browser and go the the following address:

http://printerip

And see if you get to a login prompt for the the printer user interface.  Secondly make sure you can ping the printer IP address once you are logged into the local network where the printer is installed.

Author

Commented:
Patmac951,

Ok., tried that and I am able to ping and get to the printer interface.
Commented:
Looking at the text file that accompanies the RFU file, it says you can also use FTP.  It has step-by-step instructions.  Since you already know the printer's ip address, this might be a reasonable solution.

Author

Commented:
FTP worked right from the get-go.

Still wish I knew what I was doing wrong via MS-DOS.

Thanks for everyone's help.

Commented:
Sounds bizrre way of updating with copying to a share on the device!  I imagine it involved NOT going through share from Windows host but direct to the printer itself perhaps , i.e.

\\printerip\whatever

maybe from cmd.exe prompt then this would give you answer:

net view \\printerip
or start | run button and type in \\printerip

steve