Open Word 2010 Document through IE9 without Downloading

I have a web page which links to a whole bunch of Office 2010 documents, and when a user clicks on the link in Internet Explorer 9 - it prompts the user if they want to Download the File, as per the following prompt:

File Download Prompt
I know how to get rid of that prompt - simply check the box, but the issue is that it's Dowloading the file, and then opening the downloaded file, rather than opening up the file in situ.  It (either IE9 or Word 2010) downloads the file to something like C:\Users\%username%\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.Word\~WRF{840ADEF3-F6F0-4F59-9B03-8B907F0C4E66}.tmp, and then opens the file in read-only mode.

While all of this doesn't seem to be an issue, the issue comes when the document has macros.  Some of these documents are forms for users to fill in, and when the macros don't run, the forms become useless.  These documents are in .dotm format.

What I have tried so far:

I've changed IE9 Intranet Settings to be Low
I've changed IE9 Intranet Sites to include all network paths (UNCs)
In Word 2010 Trust Center, I've enabled all macros (just for testing purposes)

Just a recap - having the full path in my clipboard and pasting into Windows Explorer opens the document in situ and without issues.  Pasting into Internet Explorer downloads the document to a temporary location and does not open the document with macros.

Any suggestions how I can make IE9/Word 2010 treat this as a standard document and open it from the actual location rather than downloading it?

Thanks in advance!
LVL 18
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Can you check changing the default IE location ( Temp Internet Files location ) to some other location as mentioned in the below article .

Check changing using registry .,. Try your above steps ... And let me know :)
the browser can only work from the local client.  It is always going to download.  That is how the technology is designed to work.  Browsers are not capable of maintain an open connection once the download is complete.  Office applications use a different protocol for accessing remote files and can maintain state.  As for the macros they may or may not be getting downloaded, but the browser probably cannot execute them anyway depending on what they are written in.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LesterClaytonAuthor Commented:
Thanks for confirming that this is the standard behavior and not much we can do about it :)
I rather be able to tell you how to it, but sometimes it just won't do what we would like.  

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Word

From novice to tech pro — start learning today.