We help IT Professionals succeed at work.

Unable to delete or rename folders on shared folders

I'm trying to delete 2 empty sub-folders inside my shared folders (on my server) but kept running into various problems (please refer to screenshots for detail) ...

So far I have tried many ways to resolve but all failed to work...below are some steps I have tried -

a) Remove all users from the main folder's security & permn settings (so no single user can touch the files inside )

b) took ownership of the main folder & all sub-folders

c) check server's 'shared files' for locked files (there were none...!)

d) tried to delete (or rename) under command prompt using 'del', deltree, ren, etc but all failed

e) try deletion (or rename) locally at server end  - also failed

I suspect there are 'hidden character' in the filename not recognised by Windows as I can 'see' it clearly at the end of the filename when it start to blink during rename/F2....but have no idea how to resolve the issue.
 
Unable-to-delete-or-rename-folde.pdf
Comment
Watch Question

Commented:
You might have already tried but can you confirm you have gone through this faq. http://support.microsoft.com/kb/320081
Are you able to shorten the name of the folder and try and delete it? otherwise try and shorten the name of the folders above it and then try and delete it.

when you look at the folder properties, is the folder "read-Only"?
If you can access the folder from a command prompt, and *if* you have 8.3 filename notation turned on, type DIR /X at the command prompt, and see if you get an 8.3 filename for the folder in question.

If you do, you may be lucky and be able to issue the DEL command on the 8.3 filename of the folder.

I was going to point you to KB320081 too...

Author

Commented:
Please refer to my feedback as below...

1. Shortening folder name - I have already tried this-it didn't work ....Actually its the same as trying to rename the folder (which produce the same error msg - just that I did not include it in the screenshot).

2.'Read-only' in folder properties - Again I have already tried this - both attributes for 'read-only' and 'hidden' are already unchecked.

3.MS KB320081 - As for the KB link you supplied, I have already tried a few resolutions eg taking ownership of file/folder, file in use, rename or move a deep folder - all did not work. As for the other more complicated resolutions - I do not want to try them out as it's quite a time-consuming task to undertake for 2 empty folders.

Actually, I still think the whole problem is due to the hidden special characters within the 2 folder names. Anyway,right now I decide to just leave the 2 folders alone and take up a suggestion from another tech site - and that is to ran a 'chkdsk' on the RAID volume and hopefully, this will resolve the problem. For this, I need to plan for a appropriate time & date as I need to down the server during 'chkdsk' operations.

Thanks for all your tips and advise ....I will update you once I got the outcome after I ran 'chkdsk' .
Commented:
In a pinch with names.. you could attempt the following.. boot up from a linux cd. mount the necessary drive and rename from within linux. Have done this before for some drives that i wrote to through my linux partition and then windows gave me hell when i switched to it.
From the server side, be certain that no other user is accessing the folders and delete from there.

If an other user is accessing the folder or files, (on the server 2003) right click on my computer, select manage, select Shared Folders (under System tools) under Open Files, you can see if a user is accessing said folder or file within ... and under Sessions you can disconnect said user....

Then you should be able to delete folders.

If this still does not work, use file unlocker on the server side.

Commented:
One thing that has worked for me in the past is to right-click, choose "Properties", click the "Customize" tab and change the folder type. This, of course, is after following the instructions at http://support.microsoft.com/kb/320081 (assuming none of the solutions there work). No idea why it works but it does.