Unable to receive email messages with attachments

None of the users on our domain are able to receive emails with attachments. Text-only emails go through with no problem, but we cannot receive any messages with attachments, even internally. No NDR or any other error message comes up, they seem to just disappear.

We are running Exchange 2007 on an SBS 2008 server. I have not changed any configuration options at all recently, and the setup is mostly default settings. I have tried looking for any settings regarding attachment handling, but have not had a great deal of experience in the deeper parts of Exchange.

How can these messages be disappearing without even an error to the sender that it didn't go through?
AidaPakITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sikhumbuzo NtsadaIT AdministrationCommented:
You don't have a spam filter?
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
its possible issue with attachment size , just for try follow this link and change the size of attached email :

http://exchangepedia.com/2007/09/exchange-server-2007-setting-message-size-limits.html

0
AidaPakITAuthor Commented:
the only spam filtering we have is the "Anti-Spam" options in Exchange. I have content filtering set to dump it to a quarantine mailbox if it thinks it is spam. There are plenty of messages getting caught by this filter, but none of the messages with attachments are making it here.

I checked all of those size settings and they are all 20mb or higher, and these are very small attachments, less than 1mb, trying to come through.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
you did not mention that you have anti spam this making things easier , what anti spam you use?
0
AidaPakITAuthor Commented:
The only filtering I have enabled is Exchange's anti-spam options, and it only filters "possible" items to a separate mailbox. The messages I am expecting are not showing up there.

Also, this would not explain why I can't send attachments internally either. A spam filter shouldn't be blocking internal mail?
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
try to run this code on powershell :


Set-ContentFilterConfig -BypassedSenderDomains yourdomain.local

Open in new window

and restart spam services
0
AidaPakITAuthor Commented:
I ran that command, but am still not able to receive anything with an attachment, internally or otherwise.
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
ok  review your antispam filter settings :

http://www.exchange-genie.com/2007/12/exchange-2007-anti-spam/

also check the users PC's its possible that someone have spyware which is making your local email blocked automatically  i advice malwarebytes :
www.malwarebytes.org

just try
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AidaPakITAuthor Commented:
As a test, i disabled all spam filtering temporarily, and am still not receiving attachments. There seems to be something else at play here.

Also, it is not just one computer or user. This seems to be domain-wide. Even with most of our PCs turned off, and just my smart phone connecting to exchange, I am not seeing the messages with attachments showing up. I ran scans on some uers' systems, but nothing came up.

Messages without attachments are going through just fine, both internally and externally. It seem like there is a setting or a configuration that is blocking or trapping the attachments?
0
AidaPakITAuthor Commented:
Something else that may or may not be helpful. It is attachments of any size, even only a few kb, that are not getting through, but messages that are larger (500k+) just from a lot of text and have no attachment still go through fine.
0
Sikhumbuzo NtsadaIT AdministrationCommented:
Try this with you:

Set-Mailbox "santasi" -MaxSendSize 20Mb -MaxReceiveSize 20Mb

Or check the following

 Global Settings tab -> Transport Settings -> Max Receive size (20MB)

 Send Connectors -> Maximum Message Size (20MB)


 Receive Connectors -> select a connector -> Properties -> General tab -
Maximum Message Size (20MB)

0
AidaPakITAuthor Commented:
I have checked all the size settings, and they are all set to 20MB or higher. It doesn't seem to be a size issue, rather an attachment issue. Emails with a lot of text that are 500kb+ go through, but an email with even a 20kb attachment is disappearing along the way.

The drive the exchange database is on as hundreds of GB free, so it doesn't seem to be a space limitation. None of the settings have changed an no updates have been applied since well before this started happening .
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
just silly question , did you try to reboot your exchange server and try again??? its possible to be solution for problem... trust me this IT problems sometimes the solution could be very silly
0
AidaPakITAuthor Commented:
Ha, i know what you mean. I had rebooted the server, and that had not changed anything.

Strangely, it has started working again. I do not believe I have changed anything, which has me a little concerned as to what originally caused it, but I am receiving attachments for all recipients again, so I guess I can close this. Thanks for you input.
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
lol , its microsoft , always stop with no reason ...good luck man
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
also i doubt something , its the SMTP queue possible that something was there as its full or rejected in the queue just for knowledge check your smtp queue and tell me what did you find
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.