We help IT Professionals succeed at work.

AT&T Samsung Galaxy S II Skyrocket Android 2.3 Wi-Fi problems with specific Acess Point

Hi, I have an AT&T Samsung Galaxy S II Skyrocket smarphone (Android 2.3) problem/question pertaining to a specific Wi-Fi network connection at my office which keeps keeps turning off my wife whenever I attempt to connect to it. I have full control over the Wireless Router and I have checked the security settings and there is nothing in the settings that would indicate that I should not be able to connect my phone to it. In fact my laptop and my kindle fire devices are connecting to the Access point just fine without any problems. Also, my phone works fine with my home wireless router and at any other hot spot so it is not a phone malfunction, but it seems to me that it is specific to the Access Point at my office, but I cannot figure out what could be causing my phone Wi-Fi to turn off the minute that I try to connect to my office AP. Please let me know if there is something I can do to fix this. I already contacted AT&T tech support and they could not figure out the problem either. Thanks in advance!
Comment
Watch Question

It would help to know the make and model of the access point as well as the firmware version it is running.

Additionally how is the access point configured?  WEP/WPA/WPA2? PSK? TKIP/AES? (I use the acronyms as that is likely how they appear in a web console...)
after connecting to AP assign a static IP address and see
Systems Admininistrator
Commented:
The Wireless Router I am using is a Cisco WRVS4400N Wireless-N Gigabit Security Router with VPN.  I had tried the different encryption modes but that was not the problem, but I found out that the cause of my disconnection was the router's Wireless Network Mode which was set to "B/G/N Mixed Mode" and as soon as I changed it to "N-Only" then my phone was able to connect and stay connected.

Anyways, thanks!  I do appreciate your reponses but the problem is now resolved.
Jaime BonillaSystems Admininistrator

Author

Commented:
I found the solution.  Thanks!