We help IT Professionals succeed at work.

IIS VB+>net

I have the following code on startup

     Dim props As New Collections.Specialized.ListDictionary()
        props.Add("useDefaultCredentials", True)
        _channel = New HttpChannel(props, New SoapClientFormatterSinkProvider(), New SoapServerFormatterSinkProvider())
        ChannelServices.RegisterChannel(_channel, False)
   
The virtual directory is set to Read and the authentication and access control is set to Integrated Windows authentication, the problem is this works fine for the read but when I try and call one of the dlls to write something I get an access error. The only way I seem to be able to overcome this is by setting Enable Anonymous Access and specifying myself as a user.

Any help?

Comment
Watch Question

create a new application pool in iis and make it run using the local system account. use this application pool for your application. Should work.

Author

Commented:
Under application settings should I set scripts and executables, it is set to scripts currently
yes you could try that, did u also try running the app pool as local system account?

Author

Commented:
Where do you set that, is it in the directory properties?