We help IT Professionals succeed at work.

Exchange 2010 - OWA Not working

tricom2007
tricom2007 asked
on
Exchange 2010 OWA not working on inside. Outside works fine.

running on 2008 R2


get certifiicate warning, then blank page.

help!


Comment
Watch Question

Probably is something you configured on IIS.

Go CAS Server, IIS, Default First Site, OWA v directory - SSL Settings, set it to Ignore, restart IIS.

Go to CAS, IE, type https://internalCASname/owa.

Let me know if it helped you.

Author

Commented:
OWA v directy was/is set to Ingnore.  
How is it configured in CAS?

 Now for the Outlook Web Apps, Exchange Control Panel, Exchange ActiveSync, Offline Address book…you have to go to Exchange Management Console (EMC)

   1 - Goto one of the CAS server
   2 - Open EMC
   3 - Goto Server Configuration
   4 - Select Client Access
   5 - On the Middle top pannel, you can see the CAS server listed.
   6 - Select one server.
   7 - Select OWA directory, right-click Properties and change InternalURL to your http://internalCASname/OWA. (without SSL).

Restart IIS and test it again.

Author

Commented:
could this be authentication?  again it works on the outside not on the inside.  One more twist, iPhones are no longer receiving mail.
If none of this helped, please attach a picture from OWA directory in EMC for info.

Let me know if it helped you.

Author

Commented:
not sure exactly what you wanted to see.  Here's a screenshot from EMC.

let me know if this is not what you were looking for.

thanks!
owa.jpg
You said that when you access internally it displays a error: Might be because you dont have phpmail.... into your SAN Cert.

Other thing i notice is that your internal fqdn is the same as your external is that right?

So there is some ways of solving this:

USING SAME NAMES INTERNALLY/EXTERNALLY

1 - If your internal DNS is equal to your external, you might create a A type DNS register internally pointing to your external working address;

2 - If your internal DNS is equal to your external, you might add your phpmail into your SAN certification and access it.


USING DIFFERENT NAMES INTERNALLY/EXTERNALLY

1 - If your internal DNS is different form External DNS, change your internal URL to your http://servername.domain/owa

2 - Check in your internal DNS if your servername leads to your server.

After doing any change, restart IIS.

Let me know if it helped you.

Author

Commented:
when you access the url in a browser, you get a certificate warning, click to proceed, then a blank screen... only on the inside. from the outside you get the certificate warning, then you get the OWA login and everything is fine.

yes, internally, DNS resolves servername.domainname.com ---->local IP of CAS Server

Ok, add your internal servername to certificate to it. If it is already.

Please check some similar issues:

This seems to be more right: http://www.stefanjagger.co.uk/03/default-exchange-2010-owa-shows-blank-page/

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_25596264.html

Let me know if it helped you.

Author

Commented:
set the certificate, still not working.


thanks,


Have done all the steps in links listed?

If yes, i think it might be something with patches, you might install RU6 for Exchange SP1 or SP2(this one will lead you to update schema).

Have you tried to point your internal users to your external OWA name?

Author

Commented:
yes, i've tried all the steps, including pointing to users to external domain name. I am going to install the latest rollup and go from there. thanks for your help.  i'll post the results, it will most likely be in the next 24 hours.
Ok, i will wait and if you have any more issues, please post.

Have a nice day mate.
this was caused by rollup 6.  I uninstalled rollup 6 then re-installed rollup 6 and it fixed the issue

Author

Commented:
Reinstalling Rollup 6 resolved the issue
I do have an objection.

We as Experts were trying to help him out and we tried to explain it to him. As he made an action that were suggested to one of us, the question points must go to one expert.