Opening All Firewall Ports

How can I open all ports with Windows XP firewall enabled?
PeterSchenkAsked:
Who is Participating?
 
Tony GiangrecoConnect With a Mentor Commented:
Sorry, I didn't read your question entirely. There are thousamds of ports in windows. if you really wanted to, you would need to expliciidly open each port or create a rule to allow access to all for all realsons. That said, this is not an easy task in Windows.

Also it would not make any sense becase opening al ports is basicly the same as turning off the firewall, so why go to all that extra work of opening each port seperatly?

Also your router probably has a firewall, so those ports or firwall protection would need to be disabled to really open it up.
0
 
☠ MASQ ☠Commented:
If you want all your ports open why do you want the firewall enabled? What will you use it for?
0
 
Tony GiangrecoCommented:
If you really want to open all the firewall ports, go into control panel, Windows Firewall and select Turn Off.

Note: This opens your Pc up to hackers, viruses and spyware.

You can quickly re-enable the firewwall. Just click Turn Firewall On.
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
eXpeLLeD_4RM_heLLCommented:
Easiest way to open all ports is to disable all Firewalls, that is both software and hardware firewalls.
The big question is WHY??????
0
 
PeterSchenkAuthor Commented:
We have a program that requires a certain port to be locked down to a single incoming IP address.  To do this we had to turn on the firewall wall then soon discovered all the other stuff that stops working because we turned it on.  

I checked out port blockers on the internet and could not find a product to do what we needed.
0
 
MaurizioSchmidtCommented:
if you dont want to communitcate to only ONE ip, do the following:

go to:

C:\Windows\System32\drivers\etc\HOSTS edit this file like

127.0.0.1           type_here_the_url_where_the_system_should_NOT_communicate_with

close the file, reboot, done.

we dont have to discuss that using a system without firewall is a big issue.
0
 
PeterSchenkAuthor Commented:
Your not understanding my issue....

Some machines on our LAN need to have a port locked down only allowing one IP address inbound on that port.  Windows Fires wall can do this easily but now creates all kinds of issues by turning on the firewall.  Your suggestion with the hosts file will not do this.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.