Line number for each record in a report

Hi experts,

I have a Ms Access report based on a query with the following parameter:
FROM [qryClientList]
WHERE ((([qryClientList].Facilitator)=[Forms]![frmFacilitatorName]![cboCRF]) AND (([qryClientList].Filestatus)="active"))
The report is running okay, only when I added the line number for each record, no matter it's overall or over group, the consecutive number doesn't go to the next page. It starts all over again from 1 for each page.
When I deleted the parameter, the line numbers are okay for the entire report.
How do I keep the paremeter and let the number work?

Thank you!

LL
howruaz9Asked:
Who is Participating?
 
Jeffrey CoachmanConnect With a Mentor MIS LiasonCommented:
I don't know how you created/added your line numbers, ...but try this, it woks fine for me filtered.

So in my case I am opening the report with a filter, and leaving the source table/query alone (no parameter)



Access-EEQ-ReportLine-Numbers.mdb
0
 
Jeffrey CoachmanConnect With a Mentor MIS LiasonCommented:
here is the code for two filters (text for name, and a numeric range for Amount)

DoCmd.OpenReport "YourReport", acViewPreview, , "cName=" & "'" & Me.cName & "'" & " AND " & "Amount>=" & 50
0
 
Jeffrey CoachmanConnect With a Mentor MIS LiasonCommented:
Some notes:

In my sample you can ignore the Running sum field (I based this sample on a previous sample)


By opening the report with a filter, you can leave the Reports recordsorce without any parameter criteria.
This way you can still open the report on its own (by itself without the form) without triggering the annoying parameter prompt...
;-)

Jeff
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
howruaz9Author Commented:
Hi Jeff,

I'm trying your suggestion to open the report with a filter, just to let you know while I'm working on it.

Thanks,

LL
0
 
howruaz9Author Commented:
Thank you very much, Jeff. It's working now.

I don't know what exactly I did wrong before, but I'm so glad it got fixed.

Thanks again and wish you a wonderful holiday season!!!

LL
0
 
Jeffrey CoachmanMIS LiasonCommented:
Great, thanks


;-)

Jeff
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.