Automatic Replies Access in Exchange 2010 - Outlook 2010 Slow But Good in OWA

I have 1 HT, 1 CA and 2 MB in 1 site and 1 HT, 1 CA and 1 MB at a remote site that is not facing the Internet.  Users set up Automtic Replies (ooo) in OWA fine but when using Outlook 2010, the reponse from the server can take up to 45 seconds.  During this time, the user will click the option again and again thinking it's not working making the process worse.

Any suggestions to help?
CityofSpringfieldMAAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
try to disable cache mode in single user pc , restart outlook and try , or send autoresponse directly from exchange :
http://www.dharwadkar.com/weblog/msexch_tip02
0
CityofSpringfieldMAAuthor Commented:
There is not cache mode enabled in Outlook 2010 and each user want to be able to set this in their own Outlook.
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
can you run on powershell : Get-ClientAccessServer | fl
and post result here??
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

CityofSpringfieldMAAuthor Commented:

RunspaceId                           : 5afc9379-e52d-47c9-af5a-01afd595fce5
Name                                 : EXCH-localHTCAMB
Fqdn                                 : Exch-localHTCAMB.DOMAIN.LAN
OutlookAnywhereEnabled               : True
AutoDiscoverServiceCN                : EXCH-localHTCAMB
AutoDiscoverServiceClassName         : ms-Exchange-AutoDiscover-Service
AutoDiscoverServiceInternalUri       :

https://mail.externaldomain.com/autodiscover/autodiscover.xml
AutoDiscoverServiceGuid              : 77378f46-2c66-4aa9-a6a6-3e7a48b19596
AutoDiscoverSiteScope                : {localdatabase1}
AlternateServiceAccountConfiguration :
IrmLogEnabled                        : True
IrmLogMaxAge                         : 30.00:00:00
IrmLogMaxDirectorySize               : 250 MB (262,144,000 bytes)
IrmLogMaxFileSize                    : 10 MB (10,485,760 bytes)
IrmLogPath                           : C:\Program Files\Microsoft\Exchange Server\V14\Logging

\IRMLogs
MigrationLogLoggingLevel             : Information
MigrationLogFilePath                 :
MigrationLogMaxAge                   : 180.00:00:00
MigrationLogMaxDirectorySize         : 10 GB (10,737,418,240 bytes)
MigrationLogMaxFileSize              : 100 MB (104,857,600 bytes)
IsValid                              : True
ExchangeVersion                      : 0.1 (8.0.535.0)
DistinguishedName                    : CN=EXCH-localHTCAMB,CN=Servers,CN=Exchange Administrative

Group (FYDIBOHF23SPDLT),CN=Ad
                                       ministrative Groups,CN=My Organization,CN=Microsoft

Exchange,CN=Services,CN=
                                       Configuration,DC=DOMAIN,DC=LAN
Identity                             : EXCH-localHTCAMB
Guid                                 : 2894268d-edc8-4f08-992d-201c123ce2c6
ObjectCategory                       : DOMAIN.LAN/Configuration/Schema/ms-Exch-Exchange-Server
ObjectClass                          : {top, server, msExchExchangeServer}
WhenChanged                          : 1/25/2011 1:17:13 PM
WhenCreated                          : 11/23/2009 4:15:02 PM
WhenChangedUTC                       : 1/25/2011 6:17:13 PM
WhenCreatedUTC                       : 11/23/2009 9:15:02 PM
OrganizationId                       :
OriginatingServer                    : DC1.DOMAIN.LAN

RunspaceId                           : 5afc9379-e52d-47c9-af5a-01afd595fce5
Name                                 : EXCH-remoteHTCAMB
Fqdn                                 : EXCH-remoteHTCAMB.DOMAIN.LAN
OutlookAnywhereEnabled               : True
AutoDiscoverServiceCN                : Exch-remoteHTCAMB
AutoDiscoverServiceClassName         : ms-Exchange-AutoDiscover-Service
AutoDiscoverServiceInternalUri       :

https://mail.externaldomain.com/autodiscover/autodiscover.xml
AutoDiscoverServiceGuid              : 77378f46-2c66-4aa9-a6a6-3e7a48b19596
AutoDiscoverSiteScope                : {RemoteADsite}
AlternateServiceAccountConfiguration :
IrmLogEnabled                        : True
IrmLogMaxAge                         : 30.00:00:00
IrmLogMaxDirectorySize               : 250 MB (262,144,000 bytes)
IrmLogMaxFileSize                    : 10 MB (10,485,760 bytes)
IrmLogPath                           : C:\Program Files\Microsoft\Exchange Server\V14\Logging

\IRMLogs
MigrationLogLoggingLevel             : Information
MigrationLogFilePath                 :
MigrationLogMaxAge                   : 180.00:00:00
MigrationLogMaxDirectorySize         : 10 GB (10,737,418,240 bytes)
MigrationLogMaxFileSize              : 100 MB (104,857,600 bytes)
IsValid                              : True
ExchangeVersion                      : 0.1 (8.0.535.0)
DistinguishedName                    : CN=EXCH-remoteHTCAMB,CN=Servers,CN=Exchange Administrative

Group (FYDIBOHF23SPDLT),CN=
                                       Administrative Groups,CN=My Organization,CN=Microsoft

Exchange,CN=Services,C
                                       N=Configuration,DC=DOMAIN,DC=LAN
Identity                             : EXCH-remoteHTCAMB
Guid                                 : 28dbd6ca-116a-48b9-aff9-a17648d35167
ObjectCategory                       : DOMAIN.LAN/Configuration/Schema/ms-Exch-Exchange-Server
ObjectClass                          : {top, server, msExchExchangeServer}
WhenChanged                          : 10/28/2011 5:53:21 PM
WhenCreated                          : 10/28/2011 2:18:54 PM
WhenChangedUTC                       : 10/28/2011 9:53:21 PM
WhenCreatedUTC                       : 10/28/2011 6:18:54 PM
OrganizationId                       :
OriginatingServer                    : DOMAIN.LAN



0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
the problem as i can see with autodiscoverURL its should not point to remote one , its must point to local server , then you need to modify the following :

set-ClientAccessServer -identity " EXCH-localHTCAMB" -AutoDiscoverServiceInternalUri   https:// EXCH-localHTCAMB.DOMAIN.LAN/autodiscover/autodiscover.xml


set-ClientAccessServer -identity " EXCH-remoteHTCAMB" -AutoDiscoverServiceInternalUri   https://EXCH-remoteHTCAMB.DOMAIN.LAN/autodiscover/autodiscover.xml

also you need to work with autodiscover in both case server

Set-AutodiscoverVirtualDirectory -identity "autodiscover (default web site)" -InternalURL https://CasServerName.Localdomain.lan/autodiscover/autodiscover.xml -externalURL https://mail.domain.com/autodiscover/autodiscover/autodiscover.xml

you must do the last on both CAS and restart IIS , everything will back to work well , my point was that internalURL should'nt be external URL  this why you don't see free/busy..

good luck
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CityofSpringfieldMAAuthor Commented:
Wow, I knew this was going to come back and bite me.  Here's what happened, originally, that's how it was set up but I started having certificate issues with Outlook because my internal exchange servers were not listed on my Digicert Certificate and Micosoft had me reconfigure the settings to point to my external domain.

I just added all the exchangeservernames.domain.lan to the certificate and I will put the settings back to what you indicated.  (Nobody realized that they were not seeing free/busy yet.)

Microsoft also had me change the Set-Webservicesvirtualdirectory and Set-oabvirtualdirectory to my external doamin.  Will I have to repoint those as well?

Thank you very much for your help.
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
for internal certificate u need to create self-signed certificate using iis,just go to certification then create selfsigned with common name domain.local
Then goto powershell and run this command:
Get-exchangecertificate
You will have 2 certificate look to the one have cn=domain.local,look at the thumbprint in hex format,copy it then run command :
Enable-exchangecertificate -thumbprint "the thumb print that you copied" -services pop,smtp,imap
Then goto client access check if pop and imap have certification x.9 something like this i cant remeber i am typing from mobile,check if the name is the same exchange server name just server name without domain,i mean like this "exchangeserver",but withou "",then restart exchanges services,you will get it work,do same on the 2nd CAS.
Good luck.
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
for other webservice that need internalurl,you should set them to internal,just change external domain in the path to internal like
Server.domain.local/ews/...bla bla,just do with internal and leave external as well,when u finish restart iis,also disable ipv6 in u r server if its not in production. Then test your email using:
www.testexchangeconnectivity.com
Its trusted microsoft site,and then post results incase of any problem,in the morning i will check that,i have to sleep its 1:.40 Am,here in amman-jordan,as u know in the morning i have work.
Wish to you good luck
0
CityofSpringfieldMAAuthor Commented:
Thank you very much for your help, I put things back the way they were like you said and my issue is resolved.  I did run a test to testexchangeconnectivity.com and got ssl errors on a name inside the certificate not related to exchange.  I will investigate later.  Thanks again.
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
am glad to hear that your problem has been solved , can you post the error you faced in ssl?
0
CityofSpringfieldMAAuthor Commented:
I just need to add autodiscover.externaldomain.com in my Certificate eventhough it's seems to be working ok for now.
Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.