Windows 7 Remote Desktop connection issues

Hey experts,

I have encountered this issue twice now where the Windows 7 Professional PC is unable to be connected to via RDP. In both cases, the PC is acting as a file server and has SERVER as part of the Full Computer Name. These PCs, however, are NOT part of a domain - just a workgroup. As with other successful RDP setups I've completed, I have done the following:

1/ Set up a dns host name correctly with correct local 'host' internet IP (as confirmed via www.whatismyip.com)
2/ Visited START>CONTROL PANEL>SYSTEM>REMOTE SETTINGS on the host PC and clicked on bullet point relating to 'allowing connections from computers running any version of remote desktop'.
3/ In the same window above, clicked on 'select users' and added 'Everyone' to the list.
4/ Accessed the firewall and creating a new inbound rule for a new port (3390)
5/ Changed the listening port via regedit (to 3390)
6/ Restarted PC

I am stumped! Accessing mstsc, entering <hostname>:3390 (even replacing the hostname with the internet IP) and clicking 'connect' only produces the following message after about 20 seconds:

"Remote Desktop can't connect to the remote computer for one of these reasons:

1) Remote access to the server is not enabled
2) The remote computer is turned off
3) The remote computer is not available on the network

Make sure the remote computer is turned on and connected to the network, and that remote access is enabled.

Incidentally, when setting up rdp, I can usually rdp into my work PC offsite from the PC I'm setting us and then rdp back from my work PC to the PC I'm setting up just to confirm that the connection is being made (which I know because I get bumped off). In both of these cases, I can rdp to my work PC just fine, but get the message above when trying the reverse.

Thanks in advance, experts - I look forward to hearing from you soon as this one's doing my head in.
Servant-LeggieAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AirShieldCommented:
Hello,

Are you able to connect to the pc from within the network not over the internet?
0
Servant-LeggieAuthor Commented:
Airshield, the PC has shared folders which can be accessed via drive mapping on other PCs. As far as via mstsc, I enter the <Full PC name>:3390 and try to connect, but no luck. That said, I haven't tried the <Local IP>:3390 ...
0
AirShieldCommented:
Please try the local IP from the local network if that doesnt work, try to connect without ":3390" just to test.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

Servant-LeggieAuthor Commented:
As it's a client PC, I won't be able to check until this afternoon. It that works/ doesn't, where to then (I know that's a bit vague, but I really need a process heading in).
0
AirShieldCommented:
Well,

Right now I am thinking firewall, what Antivirus is installed? does it have a built in firewall?, also did you open that port in the Windows Firewall?
0
ythevenotCommented:
hi,
if you can RDP with the local IP address and port 3390, then you have to check your gateway settings (firewall, ADSL modem...), make sure the port redirection and IP redirection is done correctly (you can test with changing the internal IP to a different PC).
if you cannot RDP with port 3390, but can RDP to port 3389 (still with the local IP) then check your registry change as the listening port has not been changed.
if you cannot RDP at all then check the services on the computer to make sure that firewall is correctly configured, check remote service is started.

regards,
Yannick
0
Servant-LeggieAuthor Commented:
ythevenot, I have checked the listening port (as mentioned in original post) and that's good. Port forwarding is fine on the router (I set it up at the same time with other new Windows 7 PCs recently deployed on that network and it worked perfectly. I checked the services (there are 3 which are supposed to be 'STARTED' and they are. I disable the firewall temporarily, just in case it was that, but no change.

Airshield, using NOD32 which doesn't have a firewall. I have created a new inbound rule for that port in the firewall (as mentioned in original post) and that all looks good.
0
Servant-LeggieAuthor Commented:
No, can't access the PC from the local network via mstsc whether noting the port number or not.
0
AirShieldCommented:
Hello,

Try with this option instead: "Allow connections only from computers running Remote Desktop with Network Level Authentication"

Disable the antivirus and the windows firewall just for testing purposes.

Try to connect from the local network with the hostname and with the ip.
0
Servant-LeggieAuthor Commented:
Hi Airshield, I'll give this a try and will let you know how it goes.
0
Servant-LeggieAuthor Commented:
Hi Lee, thanks for your comments.

Airshield, that didn't work, I'm afraid. Any other suggestions?
0
ythevenotCommented:
Can you run netstat -a in a command line and check that there is a process listening on port 3390 or 3389?
you can then use netstat -o to check the pid of the process listening to that port, the idea is to ensure that you have no other process/service using the terminal service port.
Can you also try to telnet localhost 3390 and telnet localhost 3389 on the client that has the problem?
then you repeat the same replacing localhost by local IP, next step is to check from a remote machine.
basically telnet will tell you whether there is a process listening, for example if you get an answer on localhost and anser on local IP on the machine but not on the remote machine, then you have a firewall/antivirus or other software preventing the port being accessed from outside.
If that is the case, you will need to find what software it is.
You can also check whether terminal service is working in safe mode with networking.

hope that helps,
kind regards,
Yannick
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Servant-LeggieAuthor Commented:
Hi ythevenot, I will attempt this as soon as possible and will let you know how it goes!
0
Servant-LeggieAuthor Commented:
Hi ytheevenot, I will be able to try these processes this afternoon when I visit the client.

By way of an update, I can confirm that the PC we're trying to remote to cannot be accessed via MSTSC within the network, whether we try to access via <PC name>:3389 or <IP Addy>:3389 and I can confirm that the registry settings are set to make port 3389 the default listening port.

I have temporarily disabled the Windows firewall and the antivirus (ESET Smart Security, so it DOES have an inbuilt firewall) and tried again, but the results have been the same.

The PC is connected and the mapped drives hosted on this PC are accessible elsewhere on the network.

The PC we're trying to access is a Win7Pro SP1 box.
0
Servant-LeggieAuthor Commented:
ytehevenot, accessed the PC on Friday afternoon and resolved - here's what happened.

Double-checked everything above, but it all checked out. Ran netstat -a & netstat -o and saw that 3389 (the port set up to listen for RDP service) was not listening. Went into services and found that service not only turned off, but also disabled! Very strange! Turned on and set to automatic start, ran netstat again to confirm it was listening and the connected...

...Voila! It worked!

Strange that this service, 'Remote Desktop Services' was stopped and set to disabled, even though everything has been properly set via Start>Control Panel>System>Remote settings.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.