We help IT Professionals succeed at work.

The trust relationship between this workstation and the primary domain failed.

I have a user in another office who ran a system restore. After the restore finished the computer rebooted and the following message appeared when the user tried to log in "The trust relationship between this workstation and the primary domain failed."  I have read in other threads that the easiest way to fix this problem is to log in locally, disjoin from the domain then rejoin. As I am at a different location, I cannot log in as the local admin and in fact I think the IT guy who set up this computer may have disabled the account.  Is there another way to repair the trust relationship?
Comment
Watch Question

Distinguished Expert 2019

Commented:
Without a local admin, no.
The issue is likely the result the the certificate the system has based on the restore is the former and is not seen as valid by the DC.

What restore did the user run? is the user's account a local admin?
Instead of disgoining and rejoinin, a straight rejoin might do the trick, but the user's account has to have rights to join systems to the domain.

Commented:
Hi JDI-IT,

1. Switch the PC off.
2. Unplug the network cable.
3. Power op the PC.
4. Login with domain account as per normal. (will login like a notebook when at home)
5. Plug network cable in after login.
6. Go to domain settings. change domain from: "domain.com" (or whatever the domain name might be) to  just "domain" (without the .com / whatever)
7. you will be prompted for username and password - supply details.
8. restart as per request.
Problem solved

There is Linux boot apps out there that can reset / enable local admin account again. but might require you to be in front of the PC.

HTH

Commented:
Note: if the user can follow your instructions over the phone - give that account temp domain admin access and remove after reboot. (will prevent them from sending you the PC or you going there)

Author

Commented:
The system restore was just the built-in microsoft system restore.  As far as I know the user didn't have local admin rights and is currently locked out of the computer.

Author

Commented:
Thanks for the replies.  I tried Moomin83's method with no success.  I have an Ultimate boot disk that also didn't seem to work.  Any other ideas?
Commented:
Looks like the system restore point was corrupted.  Restoring back to the original point fixed the issue.

Author

Commented:
My reason solved the issue