We help IT Professionals succeed at work.

VLANS Issue

itubaf
itubaf asked
on
Dear Experts,

i have two networks, 10.10.10.x and 192.168.168.x
i have one C3750G switch, i want both network to work please help.

i shoudl be able to ping both interfaces.
Comment
Watch Question

Commented:
You need a router somewhere.

Add a static route to the router with the specific interface to reach each network.

Author

Commented:
thanks for reply
i have Sonicwall firewall/router but i dont know how to add routes in it.

Commented:
Forget about SonicWall. at least for now. You have L3 switch (which is basically a router) so it's better to make L3 routing works directly on the switch.

So, to enable routing you need to have "ip route" command issued in config mode. I hope that you know how to get to config mode. If not, ask.

Also, you need two interfaces configured with 2 different networks on it.

Possibility 1. with Vlans.

from config mode you issuse these:
vlan 10
name network1
exit
int vlan 10
ip address 10.10.10.1 255.255.255.0
no shut
exit
vlan20
name network2
exit
int vlan20
ip address 192.168.168.0 255.255.255.0
no shut
exit
int gi 0/1
switchport mode access
switchport access vlan 10
no shut
exit
int gi 0/2
switchport mode access
switchport access vlan 20
no shut
exit

Possibility 2. configure address directly on interfaces

int gi 0/1
no switchport
ip address 10.10.10.1 255.255.255.0
no shut
exit
int gi 0/2
no switchport
ip address 192.168.168.0 255.255.255.0
no shut
exit

Also in both cases, don't forget to save config and make it persistent across reboots.

I would suggest to configure vlans. It gives you more possibilities and versatility.

Author

Commented:
Thanks slakic, i think Vlan option are good, but i would like to know if i create two vlan do i need to add persistent routes? if yes then we need to think other solution as i have many host @ both location replicating data and persistent routes may be very complicated.

i want a solution without persistent routes, i so have L3 switch and i can use.
Commented:
Sorry,

I'm not so sure what are you talking about.

But, I presume that you are afraid of giving persistent routes on all of the host of bot networks. I agree with you that this is bad and unmanageable.

First thing to check whether it is possible to make this L3 switch default gateway for both networks. If this is not possible, then you must consider rethinking your network topology.

As you can not do NAT on L3 switch, (aside of Catalyst 6500 series) you have few things left here.

Can you post me a scheme of you network topology?
SouljaSr.Net.Eng
Top Expert 2011
Commented:
You need to explain you network topology so we don't have to guess up a solution for you. slakic is correct. You can use the 3750 switch to route your vlans. If these are the only two networks, you won't need any static routes, except maybe on the sonicwall.
Marius GunnerudSenior Systems Engineer
Top Expert 2013
Commented:
Well first of all persistent routes is a Windows term. In networking it would be refered to as static routes.

The VLAN solution would not need any static routes as long as the VLAN interfaces have IP addresses configured on them.  As long as there is an IP address configured on the router/switch within the subenet you are trying to reach there is no need to configure routing as it is directly connected to the network.

Now if those networks are far apart with more routers between them, then routing would need to be configured.

have 2 different Vlans for each segment, since they r connected to ur layer 3 switch, assign ips to each vlans , and then all u need to do is give this command in layer 3 switch

enable ip routing