We help IT Professionals succeed at work.

Cisco ASA 5505 Routing Question

I have been tasked with installing a new firewall with a new internet connection seamlessly inside of a network that already exists. The Office is part of an MPLS network for 4 locations, so the inter-site traffic needs to not use the new firewall, and use a different internal IP address as the gateway for traffic to the other 3 locations subnets.

Our CIsco ASA has the Security Plus licensing.

On our network, the address 192.168.12.3 is the gateway for MPLS traffic, and 192.168.12.254 is the new Cisco ASA Firewall. I need to switch users via DHCP to use this new Cisco ASA firewall as their gateway to vastly increase their external bandwidth capabilities. However, when using this as a gateway, I do not know how to setup routes to point them back internally for the MPLS traffic to other sites over the T1s.

My goal is to make it so that if someone on the 192.168.12.0 or 192.168.10.0 networks tries to get to the 192.168.11.0 network (this is external over the MPLS), the next hop is set to be 192.168.12.3.

Below is the sanitized current configuration file with our public addresses replaced with X.X.X.X. I am not an expert with Cisco equipment by any means, and have fiddled with trying different Route commands to no avail. Please help.

ASA Version 8.2(5)
!
names
!
interface Ethernet0/0
 switchport access vlan 2
 speed 100
 duplex full
!
interface Ethernet0/1
!
interface Ethernet0/2
 switchport access vlan 12
!
interface Ethernet0/3
 switchport access vlan 12
!
interface Ethernet0/4
 switchport access vlan 12
!
interface Ethernet0/5
 switchport access vlan 12
!
interface Ethernet0/6
 switchport access vlan 12
!
interface Ethernet0/7
 switchport access vlan 12
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.10.254 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address X.X.X.X X.X.X.X
!
interface Vlan12
 nameif inside12
 security-level 100
 ip address 192.168.12.254 255.255.255.0
!
ftp mode passive
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list inside_access_in extended permit ip any any
access-list outside_access_in extended permit ip 192.168.10.0 255.255.255.0 any
access-list outside_access_in extended permit ip 192.168.12.0 255.255.255.0 any
access-list inside12_access_in extended permit ip any any
access-list nonat extended permit ip 192.168.10.0 255.255.255.0 192.168.12.0 255.255.255.0
access-list nonat extended permit ip 192.168.12.0 255.255.255.0 192.168.10.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu inside12 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
nat (inside12) 0 access-list nonat
nat (inside12) 1 0.0.0.0 0.0.0.0
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
access-group inside12_access_in in interface inside12
route outside 0.0.0.0 0.0.0.0 X.X.X.X 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.10.0 255.255.255.0 inside
http 192.168.12.0 255.255.255.0 inside12
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet 192.168.10.0 255.255.255.0 inside
telnet 192.168.12.0 255.255.255.0 inside12
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:bec986800a6659c0a190b28ab1488f63
: end


Comment
Watch Question

Senior infrastructure engineer
Top Expert 2012
Commented:
If you use DHCP, the easiest would be to add the route there.
If it's a windows server, use the option 'classless static route'.
 

That should give you the same result.

Author

Commented:
That is a genius and simple idea. I will be trying out in a few hours once in that office.
Ernie BeekSenior infrastructure engineer
Top Expert 2012
Commented:
Let me know if that works for you.
B.t.w. in 2003 server the option is 249 (121 is for server 2008).

Author

Commented:
This works for our DHCP clients, but is there a way to get this on statically assigned devices to work as well as a permanent thing?
Ernie BeekSenior infrastructure engineer
Top Expert 2012
Commented:
route add -p 192.168.11.0 mask 255.255.255.0 192.168.12.3
(on windows machines).

Author

Commented:
Looks good :) Thanks, and accepted

Author

Commented:
This solution solves the problem completely, although in a different way than initially intended by doing from the Cisco Firewall.
Ernie BeekSenior infrastructure engineer
Top Expert 2012

Commented:
You're welcome :)
And thx for the points.