We help IT Professionals succeed at work.

IPhone cant connect to exchange 2003

I have 2 networks, both with windows server 2003 exchange servers, 3com routers and the same setup for dhcp, dns etc

one works with IPhones picking up the exchange emails, the other doesn't - everything is identical as far as i can see.

is their something really small i could have missed?

i dont really know what information to give so anything you need just ask
Comment
Watch Question

Alan HardistyCo-Owner
Top Expert 2011

Commented:
Please work your way through my article and make sure the server is setup properly:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html

If you get stuck anywhere - please shout.

Alan

Author

Commented:
FYI, if i go to http://externalip/exchange it works so webmail is up and running

i use the phone with the external ip, domain, username, password & sll off

the phone says:

Echange Account
Unable to verify account information.

Commented:
Do you mean you have 2 networks on 1 'system'  or do you mean you have 2 networks, as in 2 separate systems?

Are the iPhones setup with the external name for you exchange server on the internet?  Then when they use wifi at the office it doesn't work?  Is that the situation?

It is probably (my guess) that one of the routers can do a 'loopback' access on the external name/IP address, and the other router is not doing that.

Try Safari and see if you can access the Internet OWA webmail from each network and compare the results.

Alan HardistyCo-Owner
Top Expert 2011

Commented:
Webmail and Activesync are totally separate - please read through my article.

Commented:
I reread the question and my brain got 'stuck' on another similar iphone question that just appeared.

Looks like you should probably disregard my post and check alanhardisty's info.  

Author

Commented:
Hi Alan,

I have fiollowed your setup and then went to my phone and set the phone up again, now using SSL on, the phone then ticket all the boxes rather than giving the usual error but when i go into look at the emails it comes up and says cannot connect to server.

when i said 2 networks i meant o completely seperate networks, not related but both installed on the same day, same updates, completely identical. you can disregard that comment as i see now it doesnt make much difference!

Thanks for your answers so far!

james
Alan HardistyCo-Owner
Top Expert 2011

Commented:
That was very quick!

What are the results on the test site?

Author

Commented:
both ports are open and not blocked - just went through everything again to confirm and everything is as the guide recomends, its sbs 2003 with exchange sp2
Alan HardistyCo-Owner
Top Expert 2011

Commented:
What about the results on the test site??  ( https://testexchangeconnectivity.com )

Commented:
I had the same issues on our Exch2003 and it just turned out to be the way we were entering the info into the phone itself...  FQDN wasn't needed, we used the Netbios name and it worked fine.

Author

Commented:
sorry:

      Connectivity Test Failed
 
Test Details
      ExRCA is testing Exchange ActiveSync.
       The Exchange ActiveSync test failed.
       
      Test Steps
       
      Attempting to resolve the host name servername.co.uk in DNS.
       The host name resolved successfully.
       
      Additional Details
      Testing TCP port 443 on host servername.co.uk to ensure it's listening and open.
       The port was opened successfully.
      Testing the SSL certificate to make sure it's valid.
       The SSL certificate failed one or more certificate validation checks.
       
      Test Steps
Alan HardistyCo-Owner
Top Expert 2011

Commented:
"The SSL certificate failed one or more certificate validation checks."

What is the name in your SSL certificate?  It has to match the FQDN you are using to access the server via.

If you need to generate a correctly name SSL certificate - follow that section in my guide.

Author

Commented:
just disabled the network card when double checking some settings, Someones been sent over now to re-enable it then i'll be back with the info for you.

thanks for the help so far, I've just realised that some of your guide never appeared the first time i loaded it so ive missed the last few steps, ill work through that once i get back on!

James
Alan HardistyCo-Owner
Top Expert 2011

Commented:
No problems - here if you need me for anything.

My guide isn't the shortest in the world - but I like to think it is pretty comprehensive :)

Author

Commented:
ok im back on, the certificate is servername.domain.local - is that correct?

im using ip addresses to connect the phones - can you do that with ssl?

error now:
      Connectivity Test Failed
 
Test Details
      ExRCA is testing Exchange ActiveSync.
       The Exchange ActiveSync test failed.
       
      Test Steps
       
      Attempting to resolve the host name redcar.domain.co.uk in DNS.
       The host name resolved successfully.
       
      Additional Details
      Testing TCP port 443 on host redcar.domain.co.uk to ensure it's listening and open.
       The port was opened successfully.
      Testing the SSL certificate to make sure it's valid.
       The SSL certificate failed one or more certificate validation checks.
       
      Test Steps
       
      ExRCA is attempting to obtain the SSL certificate from remote server redcar.domain.co.uk on port 443.
       ExRCA wasn't able to obtain the remote SSL certificate.
       
      Additional Details
       The certificate couldn't be validated because SSL negotiation wasn't successful. This could have occurred as a result of a network error or because of a problem with the certificate installation.
Co-Owner
Top Expert 2011
Commented:
No - you can't use an SSL certificate with a .local name in it as .local domains are not internet routable, thus it won't resolve in DNS outside of your domain.

If you set one up called something.domain.co.uk then it shouldn't complain. (I will hide the domain name in a few minutes).

Alan

Author

Commented:
I forwarded a supdomain to our ip and setup the certificate using the subdomain, all up and running.

Thanks for all your help, I will accept and award you the points now.

Amazing guide.

Author

Commented:
Response times great, information great, knowledge great.

Convinced me to renew my Experts Exchange -- I was unsure until today.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Excellent news - glad you are sorted and happy that you will be back for more :)

Best wishes

Alan