We help IT Professionals succeed at work.

Sage "Devmode is Null"

0writer
0writer asked
on
Hi,

I am getting an error in Sage Line 50 on a Windows XP pc whereby each time I try to hit the Export button when viewing a report, it takes me to the screen where I can select *.xls as the file type but when I try to save the file I receive the error "Devmode is NULL". I am not trying to print the report but export it to excel. I've been able to do it this same way previously.

Can anyone help?
Comment
Watch Question

Bruce DenneySage 50 Consultant and Integrator

Commented:
Do you have a printer installed?
Bruce DenneySage 50 Consultant and Integrator

Commented:
What version of Sage 50 is it?

Is it V2012?
Have you installed SP3 to it?
Have you installed the ODBC hot fix?

Author

Commented:
Yes, I have multiple printers installed. Two local HP devices and a PDF printer. It's Line 50 Financial Controller. I've not checked the level of service pack and I don't think any hotfixes are installed. I don't have support with Sage so am I able to get the hotfixes/service packs?
Sage 50 Consultant and Integrator
Commented:
Please go to help>about to get version number they look like this 18.01.02.345

Sage updates are available to all users regardless of support from

http://www.sage.co.uk/accountsupdates

I suggest a clean reinstall.

http://support.makingithappen.co.uk/guides/clean_reinstall.htm

Author

Commented:
I had already tried a fresh install but that didn't help. Running all available updates and bringing the product up to date did the trick, thanks!