We help IT Professionals succeed at work.

After moving the users to a new mailserver some users cant connect with POP3

NAF-Data
NAF-Data asked
on
We have moved all our users from an old Exchange 2003 to a new Exchange 2010 SP1 server. There was no problem regarding the moving process. All users can log in with OWA on the new server. But there are still some users who want to use Outlook Express. And some of these users experience the same problem: They cannot download new emails.

This problem does not occure for all the users, some have 2 different computers with 2 different account, and it work on one computer but not the other. The error message they receive is:

There was a problem login onto your mail server. You User Name was rejected. Account '%name%', Server '%serverIP%', Protocol: POP3, Server Response: '-ERR Command is not valid in this state', Port 110, Secure(SSL): No, Server Error: 0x800CCC90, Error Number: 0x800CCC91

I have notices that this occurs on different OS, on some machines there are anti virus, and some do not have anti virus. Some run OE and some run Outlook 2010. So I cannot see a pattern on the computers that dont get the connection. And keep in mind that these users can still logon the OWA, so I know we are using the right username/password.

So does anyone have any good tip to possible solution to this problem?
Comment
Watch Question

Commented:
in the mail settings for POP3 it lists port 110 (that's correct) but it also shows SSL

check if any box is enabled for SSL and try to uncheck the box.

Author

Commented:
I have already checked, and noone are using SSL. It is unchecked from before. I have also tried to check it, and uncheck it.

Commented:
on the machine that has a problem, try to disable any email scanning function in the anti-virus program.  Have you tried that?

Author

Commented:
yes, we have also tried to disable the scanning of POP3 mail on port 110. We actually found a computer which didnt have any antivirus and it also experienced this problem about not being able to connect to the mailserver.

The weird thing is that all the user accounts was only moved from one server to another, within the same domain, all we had to do was to change the last numbers on the incoming POP3 mailserver. So why should this problem occur??

Commented:
I would try this at a computer that has a problem
open dos window
telnet serverIP 110
user username
pass password
list
quit


That will open a pop3 connection and then log you into the mailbox.  Maybe an error will show up during this?

If the list command shows the mail messages then you know that the server side / user account / and general PC should be Fine.  I would then focus on the mail client.
I would delete the POP3 mail account at the PC and setup a new POP3 mail account - something like that.

Author

Commented:
I tried that and this is what happens:

my command: Telnet 10.1.4.234 110

the terminal response: +OK The Microsoft Excahnge POP3 service is ready.

my command: user %username%

The terminal resonse: -ERR Command is not valid in this state.

-ERR Protocol errro. 19
Connection is closed. 21



So, what does this mean? What do I need to do?

Commented:
I don't know what that exactly means, but I would think it's something on your PC

is there is any AV or anti-malware or anti-spam software running on the PC that could be interfering somehow?  Can you uninstall it temporarily to see if it is causing the problem.

for the computers that do work, can you try that command again just to compare the results.

Commented:
I found a couple of things

Check the setting for Secure Password Authentication on the computers - 1that does not work and 1 that does work

On the Tools menu, click Accounts.
In Internet Accounts, click the Mail tab, click the name of your POP3 e-mail account, and then click Properties.
Click the Servers tab, and then click Log on using Secure Password Authentication.


this page looks good with steps to identify if there is a problem or configuration that needs changing

http://completedevelopment.blogspot.com/2009/01/enabling-pop3imap-in-exchange-server.html

Author

Commented:
I have tried to use Secure Password Authentication, this did not help. I also tried on computers that dont even have antivirus, and the problem remains. So Im clueless.

Commented:
Did you try the telnet stuff from a working computer that can get email via POP3 ? did you get the same error in telnet?

Author

Commented:
I just did, and the Telnet session went without any problems:

Telnet 10.1.4.234 110
+OK The Microsoft Exchange POP3 service is ready.
user %username%
+OK
pass %password%
+OK User successfully logged on.


So, any suggestions to any solution?

Commented:
I found this page.  
http://msexchangetips.blogspot.com/2007/11/exchange-2007-pop3-err-command-is-not.html

But if you can telnet from a different machine then I would not suspect the server configuration.

To further test this idea I would suggest this.

From a working machine telenet to mail.google.com 110  (or any POP3 account server that you can use to test with) to make sure you can get out to the internet (ie no firewall is blocking port 110 access to the internet).
If you can access port 110 on the internet then I would try telnet mail.google.com 110   from the non-working machine and try that.
If you get the same error again then I would think that something on the workstation is causing the problem.  I would remove all AV type of software on the PC and then test to your Exchange server again for POP3.
If you can successfully connect POP3 on the internet on the problem machine (without removing the AV) then maybe look at the server configuration (in the link I provided).

Also, when you did the telnet test from a working machine, you used the same user account as the machine that has a problem, right?  

Author

Commented:
After a restart of the POP3 on one of the HUB/CAS server things started to work. Now it seems that all is good.