• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 322
  • Last Modified:

Exchange 2003 + Iphone

I was wondering if any one could lend a hand on the issue I am having. I have 1 user out of many that cannot connect to our Microsoft Exchange server from his Iphone. If I enter the credentials of another person from that office it connects right away and I am able to see email just fine. But when I enter his credentials I get unable to verify accounty information. I can however log into OWA with no problems. Any help or tips on this issue is appreciated.  Also I want to add I have compared the accounts and everything is identical.
0
jwil320
Asked:
jwil320
1 Solution
 
PaulD77Commented:
Make sure the users phone is updated with the most current OS.   Make sure in exchange IMAP4 is enabled for that user.
0
 
jwil320Author Commented:
I am trying it from my Iphone and it is up to date.

As far as IMAP4 we are only using HTTPS and SMTP.
0
 
jwil320Author Commented:
Here is a screen shot of the features the user has.
Exchange-Features.docx
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
PaulD77Commented:
hmmm what security groups is your account a memebr or not a memeber of  ? Use a user that connects fine and compare what groups they are in to yours.  Have you had mobile devices connected before in the past?  Since it's just your account and other accounts connect fine to the same phone, has to be some sort of permission, or just a small thing in exchange
0
 
FDiskWizardCommented:
For giggles I would delete the device's association from the remote management in Exchange.
2003 it was http://server/RemoteAdmin

Has the user recently changed their password?
(ALTools qan show you that easily.)

Have you looked at logs on OWA/Activesync and on Exchange server?
Usually in these cases the errors are not very helpful.

But it sounds like you have isolated that the issue is with the USER/Mailbox. For another shot in the dark, I would possibly move the mailbox to another store. Assuming password is not the issue.

ALTOOLS will also point bad logins, and the DC where bad logins are happening should show in the security log if it is from your Activesync server.

All of these phones doing email makes for lots of fun!

0
 
jwil320Author Commented:
The user that doesn't work and the one that does are part of the same groups. I made sure to do that before I posted.  I just tried re-creating the virtual directories but that didn't help any.

If I delete the user and re-create him will this also delete all his email?
0
 
PaulD77Commented:
no exchange keeps the mailbox for 30 days
0
 
PaulD77Commented:
BUT always make sure you have a backup just in case...
0
 
jwil320Author Commented:
hmmm how do i re-associate the new user with his old mailbox?
0
 
PaulD77Commented:
when you remove the user, the users mailbox will have a red X on it in exchange meaning it's been disconnected.  When you create the user, go to to exchange right click the mailbox and reconnect.

This article explains a bit about reconnecting...i think removing the user should be a last step though for trouble shooting an iphone.

http://social.technet.microsoft.com/Forums/en/exchangesvradmin/thread/5e168fe3-f465-4d47-bce2-55961c0516ec



0
 
jwil320Author Commented:
Thanks that worked fine. I believe it is local to his account and figured if I created it over it would fix it unless the problem is his mailbox?

Here is an error im getting from event viewer now.
EventViewer.bmp
0
 
PaulD77Commented:
Give this work around a try, I cut and paste this from a much longer string of pretty much the same issue...But look for the names of subfolders for iphone users that actually work, this thread was for pocket PC i presume

Open Outlook Web access for one of the users in question and log in. Then in
internet explorer hit CTRL-o and type the url
HTTP://servername/exchange/mailboxname/NON_IPM_SUBTREE and put a tick in
"Open as a Web folder"

Eg http://exchangeserver/exchange/tomjones/NON_IPM_SUBTREE (thats underlines
between non ipm and subtree -

This "SHOULD" open an explorer view of the contents of the NON_IPM_SUBTREE
for the user in question. When I looked here for a user that worked he had a
Microsoft-Server-Activesync folder with a subfolder PocketPC which in turn
had subfolders for the device ID's that had sync'd. The users that wouldn't
work did not have these folders (presumably they are normally auto-created
on first sync). I clicked new and created the Microsoft-Server-Activesync
folder, opened it and created the PocketPC subfolder and now that user syncs
ok. I don't know whether I had to create both or just the first folder but
I'm not changing a recipe that works.

0
 
jwil320Author Commented:
That seemed like a good idea but this is what I get.


NONIPMSUBTREE.bmp
0
 
jwil320Author Commented:
Well I take that back we might have something here. It's weird when I access the web url on the network i don't get anything but when I access it off the network I can see that the person working has a microsoft active sync folder and the one not working does not have that folder. I will let you know after lunch if adding the folder works or not.
0
 
PaulD77Commented:
Great, if you can copy a sync folder from another iphone user minus the device ID, try that...
0
 
jwil320Author Commented:
Hmmm...Well I really don't know what to do at this point. I can't access the non_ipm_subtree from IE at all but when I access it from another browser like chrome I can see the folders but can't modify anything.

Also when I use the check box for IE that says open as web folder I get an error and no folders show up. Is there a permission some where that I need to add or check to be able to view/change the folders in non_ipm_subtree?
0
 
jwil320Author Commented:
I don't know if this helps but should the web site read remote after logging into owa? I'm just not sure this server was set up right. I have inherited this from another admin. Even if I create a new user and give them domain/admin privileges I cannot connect with the IPhone. But older users I can except the one I created this post for.
 
https://exchangeserver/Remote/default.aspx
0
 
PaulD77Commented:
Ok..so NO new users can connect with iphone...exchange is totally up to date? Sp2?
0
 
jwil320Author Commented:
Correct if I create a new user I cannot connect via Iphone.

And yes sp2 is installed.
0
 
jwil320Author Commented:
Finally figured it out. Had to uncheck enable anonymous access on the exchange-oma virtual directory. Works great now. Thanks paul for sticking with me since your last post lead me to finding the answer i'll reward the points to that post. Thanks again.
0
 
PaulD77Commented:
Thanks jwil!  glad you're up and running.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Tackle projects and never again get stuck behind a technical roadblock.
Join Now