We help IT Professionals succeed at work.

RDP Printer redirection won't print, shows up in Printers though.

I have a 2008 Server R2 I recently installed.   I set up 5 users on RDP services, no domain, just a workgroup, they connect over with a username/password to access a software package.  This worked fine.  

I then wanted to set up the RDP web access, which needed RDP Session Broker, which required Active Directory and IIS.  So, I installed Active Directory, DNS, etc.  Then I installed the rest of the RDP services that wouldn't install, and followed a simple guide to set up the RDP web access.  That works fine, however, now that the domain is implemented (local machines are NOT in domain, they are still just workgroup PCs logging in via RDP), I can no longer print to redirected printers.  I'm assuming this is some kind of permissions issue as it was working flawlessly before installing active directory.

The printers show up fine in the "Devices and Printers" section, but when you print, it doesn't go anywhere, or show anything in the queue.
Comment
Watch Question

Author

Commented:
Update: On some workstations I can install the driver for the printer to the 2008 server, (AKA the Laserjet P1006), when I do this and set it to use that driver before defaulting to the Remote Desktop Easy Print, it works OK.

So, it only fails to print when using "Remote Desktop Easy Print", but I can't find any events in the event viewer to help me troubleshoot.
I fixed it.  I followed these instructions:

When a DC is being configured as a TS server, there is a standard warning message which states:
“Installing Terminal Services on a Domain Controller is not recommended. Do you want to continue?”

Resolution
1.       Click Start, search for cmd.exe
2.       Right click on cmd.exe
3.       Click on 'Run as Administrator'
4.       Type "C:\" w/o the quotation marks and then Press Enter.
5.       Type CD\Windows\System32\Spool  and then Press Enter.
6.       Type Cacls.exe PRINTERS /e /g users:C and then Press Enter.
7.       Restart the computer

From this article: http://support.microsoft.com/kb/968605/EN-US

Author

Commented:
I found the solution to my own problem.  It is detailed here.