We help IT Professionals succeed at work.

Parallel to USB printing not working

STS-Tech
STS-Tech asked
on
I’ve installed an HPLJ 4m Plus on a W7 Home PC using a “USB 2.0 to Parallel Printer Cable”.

I’m used to the adaptors that you plug the existing cable into and then it converts it to USB- this one plugs right into the back of the printer and then goes right into the USB port.  When I plug it in a “USB 2.0 printing support” device shows up in Devices and Printers but has no hardware info and no properties or anything I can adjust.
I then tried installing several drivers for the printer (including the universal print driver) on LPT1, LPT2, LPT3 and the “USB virtual port” listed in the ports section of the printer properties.  All combinations error out except when use the USB port.  Then the job appears to go through the queue but the printer does not respond.

I did also try disabling Bi-Directional support but still no luck.
Comment
Watch Question

It could be a bad adapter or cable. Have you tried switching them?

Author

Commented:
The client ordered two cables adn one USB extension.  I did try both cables.  We ended up just putting the old PCs back in place until the problem could be figured out- or until new printers could be purchased.
Are you talking about an adapter like this? http://goo.gl/esbVp
Commented:
Yep, that's the guy.  Ended up being a mute point.  New PCs had to be ordered due to a compatibility issue and we made sure they came with onboard LPT ports.

Author

Commented:
Final solution- cable not compatible.