SBS 2003 with ISA

SBS 2003 with ISA - self signed cert worked fine for years, but wanted to add RPC over HTTPS. Purchased and installed Go Daddy SSL cert for this. Installed cert, bound cert to Default Web site. Now, still cannot connect using RPC over HTTPS, and remote access via "https://mail.mydomain.com/remote" says "Error Code: 403 Forbidden. The server denied the specified Uniform Resource Locator (URL). Contact the server administrator. (12202) ". Also trying to set ISA to allow cert by running IE Connection Wizard get response: No Certificate has been requested for the default Web site in IIS. even though it has. Does anyone have any ideas. We are going to upgrade this server within a year and use SBS Server 2011 with a hardware firewall instead of SBS, but would like to make this work for now.
absadminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Larry Struckmeyer MVPCommented:
Assuming you mean Outlook Anywhere by RPC over HTTPs... Outlook Anywhere works perfectly will with SBS 2003 self signed cert, I see no reason to introduce a third party cert to the mix.

How did you introduce the cert to SBS?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
absadminAuthor Commented:
First, in IIS created temp web site, and requested and installed cert from GoDaddy. Then deleted temp web site. I think problem may be in ISA, but recommendation was to use Intenet Connection wizard to bind cert to ISA rules. this gives me an error, even though I did set cert in IIS to Default Web page as required.

this is to be used for Outlook clients to connect to the Exchange using RPC over Https, not just for OWA or RWW. These were working fine with self signed cert. But now after installing new 3rd party cert, even these are not working.IIS shows correct cert installed to Default web site. Default web rcp settings correct per MS articles, everything looks correct but nothing works.
0
footechCommented:
Check the properties of the web listener used by the RPC over HTTPs (or Outlook over the Internet, so many names for the same thing!) firewall rule, and make sure the correct certificate is being used there.
0
absadminAuthor Commented:
Sorry, guys. Have been working on other servers. Finally convinced boss to quit wasting resources on this old Server. We will be replacing this server with SBS 2011, and installing certs from start. I am going to close the question. Thanks to all who responded.
0
absadminAuthor Commented:
thanks, everyone for posting. Everything discussed kept coming back to Web listener on ISA - cert correctly installed still did not work. I am closing the question, because have convinced boss to replace this server. Thanks to all posters.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.