We help IT Professionals succeed at work.

SBS 2008

David Barman
David Barman asked
We have a MS Small Business Server 2008.  The primary functions of SBS are the Exchange/email functions.
Since migrated to 2008 from our old 2003 environment we have discovered some problems.  The first issue is the outlook out of office.  When users try to enable out of office, outlook says the server is not available.  From what I have read this is an autodiscover problem.  In order to resolve autodiscover, I have purchased and install a UCC certificate from godaddy.  Since doing so, the OOF still does not work.  In addition, I have discovered the OWA does not seem to work correctly.  If I try to use the HTTPS:// url it says:  HTTP Error 404.0 - Not Found
The resource you are looking for has been removed, had its name changed, or is temporarily unavailable

However, if I connect using the HTTP:// url, it wil bring up the login page and allow me to login.
I want to get OWA fixed, but my priority is OOF in outlook.  Could the problems be related?

When I run an Exchange Web services test I get the following:

[PS] C:\Windows\System32>test-outlookwebservices

 Id      Type Message
 --                                                                                                                                                                   ---- -------
 1003    Information About to test AutoDiscover with the e-mail address administrator@alexanderandangelas.com.
 1007    Information Testing server SERVER.alexanderandangelas.local with the published name https://server.alexanderandangelas.local/EWS/Exchange.asmx & .
 1019    Information Found a valid AutoDiscover service connection point. The AutoDiscover URL on this object is https://SERVER.alexanderandangelas.local/Autodiscover/Autodiscover.xml.
 1013    Error When contacting https://SERVER.alexanderandangelas.local/Autodiscover/Autodiscover.xml received the error The remote server returned an error: (404) Not Found.
 1006    Error The Autodiscover service could not be contacted.

THIS IS A SERIOUS PROBLEM.  Any help would be appreciated!
Watch Question

Jon BrelieSystem Architect

Is this for clients connecting locally to Exchange, or from outside your network?

With outlook open Ctrl+Click on the system tray icon and select "Connection Status"

It will list an OOF URL.  That address needs to be accessible.


Correct, when I enter that url in a web browser I get a 404.0 not found error.
Jon BrelieSystem Architect

Internally?  Externally?


I have few questions:

does Out of Office works Externally from the RWW Url?

What is the output you get when you launch outlook and at the system tray if you press open Ctrl+Click on the system tray icon and select "Test EmailAutoconfiguration"

Type your Email address and only select USE Autodiscover

Secondly you can check the following link

Also make sure all the wizards has been run successfully (like Add a Trusted certificate, and Fix my Network)

Alternatively Please check your IIS Settings Make sure autodiscover has correct authentication and SSL Selected.

By Default the settings on Auto discover should be on  

Authentication: Basic and Windows should be enabled

SSL Settings: it should be Require, Require and Ignore (Under client certificates) it should be Ignore
Jon BrelieSystem Architect

Okay, are you able to reach OWA internally?

Looks like your service URLS are not correct.


Here is the output from the Outlook test email autoconfiguration (see attached file)
I can reach OWA internally if I use http://server/owa.  Using https://server/owa I get a 404.0 error file or directory not found.


Sorry file did not attach.  Let's try again. Outlook-Test-email-autoconfigura.doc Outlook-Test-email-autoconfigura.doc
i Beleive Your Autodiscover records are not correct..

What about Your SRV Records??

Are they correctly populated on your ISP's Server

What is the out put of Nslookup for SRV record???


Can you advise how to check?
here is the command that you can try:

Start-> Run-> CMD (Elevated) (Right Click on command prompt and run as Administrator)

type the following
set type=srv
domain name

Make sure its pointing to the correct servername

If this is getting populated correctly

Then from Exchange management shell run the following

Set-ClientAccessServer -Identity SERVER4 -AutodiscoverServiceInternalUri https://mail.SERVERNAME/autodiscover/autodiscover.xml 

Set-WebServicesVirtualDirectory -Identity "SERVER4\EWS (Default Web Site)" -InternalUrl https://mail.SERVERNAME/ews/exchange.asmx

Set-OABVirtualDirectory -Identity "SERVER4\oab (Default Web Site)" -InternalUrl https://mail.SERVERNAME.com/oab


-> Then check the Out of office once again

-> Also you can check by creating a new outlook profile for the same user and then see if that makes any difference.



Here is the output for nslookup: (I don't think it is correct)

> domain alexanderandangelas.com
*** Can't find address for server alexanderandangelas.com: Non-authoritative ans
> domain alexanderandangelas.local
Server:  alexanderandangelas.local

DNS request timed out.
    timeout was 2 seconds.
*** Request to alexanderandangelas.local timed-out

This doesn't look good.  How do I fix?
Jon BrelieSystem Architect

You don't necessarily need an SRV record if you're only hosting one email domain.

Clients will check for:
and then some URLS.. can't remember off the top of my head what they are but they are something like

Do a "Get-AutoDiscoverVirtualDirectory | fl *URL" and post results.  The returned INternalURL and ExternalURL should be accessible respectively.


Here are the results:  (This doesn't seem correct)

[PS] C:\Windows\System32>Get-AutoDiscoverVirtualDirectory | fl *URL

InternalUrl :
ExternalUrl :

[PS] C:\Windows\System32>
Jon BrelieSystem Architect

Ah..  Those need to be set.  Take a look here for how to set them:



That URL talks about externalURL.  Don't I have to set internal as well?
Jon BrelieSystem Architect

Yes, you do.  I've seen this script mentioned quite a bit lately, but I haven't used or tested it myself.  It is supposed to go through and allow you to easily set all of your service URLS.



Ok.  I used the script.  Afterwards here is the result of the URL values:

[PS] C:\Windows\System32>Get-AutoDiscoverVirtualDirectory | fl *URL

InternalUrl : https://server.alexanderandangelas.local/autodiscover/autodiscover.xml/Autodiscover/Autodiscover.xml
ExternalUrl : https://mail.alexanderandangelas.com/autodiscover/autodiscover.xml/Autodiscover/Autodiscover.xml

[PS] C:\Windows\System32>

If I browse to either of the URLs I get the following:

HTTP Error 404.0 - Not Found
The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

Since the websites don't work, I assume that is a problem with autodiscover working correctly.
What would be our next step in diagnosing the issue.  I would really like to get this working before Monday.



Also, it looks like the SBS 2008 has a website issue.  See the attached screen shot.  Can't seem to figure out how to re-install the web sites. Screen shot of SBS 2008 website in SBS console


After making some changes to autodiscover site properties in IIS.  Now when I run test-outlookwebservices command.  It just prints (approx.) 4 blank lines.  No words, just blank lines.
What gives?
Are we sure that all the wizard has been ran successfully on the server

(Like, Internet Address Management wizard, or Fix My Network wizard)???


NEVER RESOLVED.  Delete message