FRx 6.7 is asking for Database credentials when set up on Win 7 Pro, 64 bit machines.

Hi.  We have an existing AX 2009 implementation, using FRx 6.7.  FRx is working fine with all our existing workstations, which are Win7 32bit.  

However, we have two new laptops running Win7 64bit OS.  FRx is exhibiting the same problem on both.  When we go to run Report Designer, after configuring the odbcad32 connections to the SQL server (prompting for Windows Authentication), upon selecting the company to run the report in, we are prompted with a 'Database Login for XYZ Company'.

I have verified that this isn't a user setup issue by logging onto a working workstation with the new user's credentials -- FRx runs fine.  I can also log into the new user's 64bit system with my credentials, and FRx fails with the same database login error.

Does anyone have any insight as to why this is happening?  It seems like FRx isn't passing the user credentials to the AX/SQL systems, but I cannot figure out why the issue seems to be limited to the new 64bit systems.


Scott
LVL 1
meelnahAsked:
Who is Participating?
 
Victoria YudinOwner / Dynamics GP ConsultantCommented:
I have installed FRx successfully on dozens of 64-bit machines.  Just did 4 installations earlier this week on Win 7 64-bit.  A couple of things from my experience:

1. Instead of clicking 'Run as administrator' on everything (which may not be an option in some cases), it is better to simply log into Windows as the local built-in administrator.  While it sounds like this should be the same thing as selecting 'Run as administrator', in my testing this is not always the case.

2. When logged into Windows as the local built-in administrator, if your Sysdata and IO_Data folders are not on the local machine, you will want to authenticate to the location of the Sysdata and IO_Data folders before starting your installation.  Simply browse out to them in Windows Explorer and you will be asked for a domain user ID and password with permissions to these.

3. You absolutely positively MUST use a 32-bit ODBC for FRx.  The 64-bit ODBC (which is the default when you go to Administrative Tools > ODBC on a b4-bit machine) will not work.  

4. I have not had any issues with installing FRx, running Service Pack 9, then Service Pack 12 (or 11) without actually launching FRx inbetween the service packs.  During the service pack installations, when you're asked for the location of the FRx install, make sure that you manually browse out to the correct location, even if it looks correct in the window.  Usually on 64-bit machines there will be one or two errors about not being able to register or not being able to find a DLL or component during the service pack installations.  While these are typically ok to simply click through and continue, make note of them in case you need to go back later and address them.
0
 
Abdulmalek_HamshoCommented:
Which FRx Service Pack is installed there?

What're the privileges of the Windows user running the FRx Designer? Can you try it with Administrator?
0
 
meelnahAuthor Commented:
Sorry if this isn't exactly what you are looking for (I am new to FRx), but we are running Release 6.7.11027.

The service pack file is labeled FRx6711027.exe.

It may be R11?  (I see R11 Release notes in teh zip file the SP came in)...

The user trying to run FRx has standard domain user privileges, but the problem is the same on the new machines whether I run FRx with her user account, a working user account, or the domain admin.
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
Abdulmalek_HamshoCommented:
Please try executing Report Designer as Administrator; Right-click it and select "Run as Administrator".
0
 
meelnahAuthor Commented:
sorry for the delay in replying...

running as administrator doesn't change the symptoms.

I have checked the dynamics blogs, and found that FRx 6.7 isn't supported on 64 bit clients.  There are many who say that they have managed to make them work, but no information on the workarounds.

Any thoughts?
0
 
Abdulmalek_HamshoCommented:
Yes, FRx is not supported on Windows 64-bit; I thought you're aware of this fact.

Yes, there's a hope to get it working on 64-bit, if it did not, then you will be most probably needing to use it on Windows x86 machine or vi Citrix.

Please refer to this guide in order to get it working:

http://d-b-s.com/homepage/Documents/frxon64bit.pdf
0
 
meelnahAuthor Commented:
Sorry.. no... FRx newbie.

I will uninstall and reinstall using the directions you sent.  The only main change would be to run the odbcad32 connector as administrator, but honestly, that seems to be where the issue lies, so that may be what I need.

I will post the results back tomorrow.

Thanks!
0
 
Abdulmalek_HamshoCommented:
Did you run FRx installation file using "Run as Administrator" before?
0
 
meelnahAuthor Commented:
I did... I didn't install the odbcad32 connector running as administrator though.  I am going to go through, uninstall everything, and attempt it once more using the document you linked to above.
0
 
meelnahAuthor Commented:
Sorry to everyone for the delay in my response.

Thanks for the added comments, victoria.  I still haven't sorted out what is going wrong with our installations.

Your comment on using the 32-bit ODBC connector got me interested, but I can confirm that I am using odbcad32.exe to build the connections to SQL.  What is odd though is that when I run odbcad32 from the 32bit Win7 workstations, there are a TON of options available when I click 'Add' under the SystemDSN tab--however, when I do the same thing using odbcad32.exe on the 64bit win7 workstations, I am only presented with SQL Server...

Regardless, time wasn't on my side to resolve the issue, so instead we installed Management Reporter, and have migrated our reports to it.

I thank you both for your assistance!
0
 
meelnahAuthor Commented:
problem not resolved, but through no fault on the part of the responders.  am closing the question and moving on... thank you for your responses!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.