ARCserve backup agent on RHEL 5

Does anyone have any information about how to go about installing the ARCserve r16 backup agent on a RHEL 5.6 server?
LVL 1
PERSJWMAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

fosiul01Commented:
installation of ARCServer Backup agent on linux is very easy .

you just have to run

chmod 755 install

./install

it will ask you few question and it will install every thing by it self

are you havign any issue ??


the installation instruction is in Linux direcoty under install.txt file

0
PERSJWMAuthor Commented:
i moved the datamoverandagent (which contains the linux directory) directory into /home and tried to run it from there.  It tells me "cannot locate the file: /home/datamoverandagent/linux/./nls/C/install.msg!"  
0
fosiul01Commented:
ok so you went to

cd /home/datamoverandagent/Linux  (exmaple)

then you type

./install

is that right ??

and you have root permission to run the program
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

PERSJWMAuthor Commented:
yes, I'm logged in as root
0
fosiul01Commented:
and you have
gcc , make packages installed ??
0
PERSJWMAuthor Commented:
Haha.  Now I really feel like an idiot.  I don't know if I do or not.
0
fosiul01Commented:
type

yum install gcc
yum install make
0
PERSJWMAuthor Commented:
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
No package gcc available.
Nothing to do
0
fosiul01Commented:
if you dont have RHN

then I will not suggest you to use Redhat ..

because you will not get any updates and packages
i will advise you to install Centos

which is a repla of Redhat and its free and its give same performace .
0
PERSJWMAuthor Commented:
This is a test system that I was trying to learn the setup procedure on.  I have production RHEL servers that do have RHN and they are registered.  So your'e saying this command should work on a system with RHN?
0
fosiul01Commented:
yes

you can try

rpm -qa | grep gcc
rpm -qa | grep make

it will tell you if you have gcc install or not



if you install centos. it will give you same thing as redhat ..

centos and redhat is same structure just name is different.
0
PERSJWMAuthor Commented:
Yes, gcc appears to exist on the production RHEL servers.  

gcc-fortran-4.1.2-51.el5
libgcc-4.1.2.51.el5
gcc-c++-4.1.2.51.el5
gcc-4.1.2-51.el5
libgcc-4.1.2-51.el5
0
fosiul01Commented:
what about this server , where you re trying to install backup agent
0
PERSJWMAuthor Commented:
Well I just tried to move the linux directory into /home, changed to that directory and attempted to run ./install again with the same error:

Can not locate the file: /home/datamoverandagent/linux/./nls/C/install.msg

When I check the /home/datamoverandagent/linux/nls/C/ directory, the "install.msg" file is there.  I don't know why it's referring to a /./ directory though.
0
fosiul01Commented:
do this way

move out the Linux directory on /root direcotry

type :
cd /home/datamoverandagent

then

move linux /root
then try

cd /root/linux

then type

chmod 755 install

then type

./nstall
 

0
PERSJWMAuthor Commented:
same error. i don' get it.  all of those commands worked as you specified.  I get what you're talking about.  I'm assuming that moving the directory to root's home folder and using the chmod command ensures that the permissions are set right to run the installation.  It's just that it keeps specifying a "." directory in the path when it says that it can't find the install.msg file.  
0
PERSJWMAuthor Commented:
I had to go into the directory "linux" and force the rpm installations:

rpm -ivh abcmagt.rpm --force
rpm -ivh abagtux.rpm --force

Then I checked to see if the agent was running:
caagent status

After these steps, I was able to add the clients to ARCserve.  Thanks for your help.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PERSJWMAuthor Commented:
Found my own solution.
0
elloco40Commented:
I found that there is a problem with the files inside the ARCserve Backup's downloadable image at arcserve.com.
I tried to install with an original DVD and it was ok, in RHEL, CentOS and Ubuntu.
Please get one and try again.

Good luck !
0
Steve-JohnsonCommented:
I am using OES (Open Enterprise Server) 11

I had a very similar error.  I found that the directory path containing the file the script was looking for had a lower case 'c' as a directory name rather than the upper case 'C' given in the error message.  I therefore renamed the directory c to C and made some progress.

I had to copy the files to the hard drive and make the script executable to achieve this of course.  Initially I was trying to install from a CD image.

I now have another error...

Here is my solution...

I succeeded in installing the agent but only by taking the following steps.
Copied the directories below datamoverandagent to /var/tmp/CA
renamed directory called c as C and rerun install (needed to make it and one other file executable)
install script then failed complaining about missing inoculan\avengine.rpm there isn't even an inoculan directory in the image (and I have no wish to install it anyway)!  Created an inoculan directory and placed in it a dummy avengine.rpm which I created following instructions to create an empty rpm file on the internet

The install then worked without problems.
If you need to backup Novell metadata (as I do) you need to investigate extended attributes e.g. /ListXattrNWMetadata and configure using nsscon.

Basically the install script is broken.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.