• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 906
  • Last Modified:

Outlook prompts for Exchange password continually

Problem statement

We have Outlook 2007 on domain workstations, with Exchange 2010. Exchange Service Pack 1 is not installed. The server is Windows 2008 R2 Standard, 64-bit. This is a virtual machine running under VMWare vSphere 4.1 Essentials
Out of about 80 people in two offices, about 10-15 now have Outlook repeatedly prompting for their Exchange password. Entering the correct credentials allows mail to flow for a short period, and then they are prompted again within a few minutes. Error message 0x8004010f, sending email passed but receiving email failed with this error. Until two days ago, the prompt only appeared if the user’s domain password had been changed, or expired. Clicking ‘Remember my password’ in the dialog has no effect.  This issue arose in response to actions taken under emergency downtime conditions two days ago.

Background
Exchange halted processing email due to the drive containing the mailbox database running low on space.  In an effort to get it running short-term, this folder was moved to the G-drive:
E:\Program Files\Microsoft\Exchange\V14\ClientAccess
Mail processing resumed, but smartphone mail access and webmail were broken.
After hours, we extended the size of the offending drive, and copied the folder that had been moved back to the original location. There were ‘file in use’ errors during copy. We stopped all Exchange services and retried with the same result, though it appeared all files were present based on a folder comparison.  We then restarted the server, tested Outlook from a workstation without issues, tested smartphone and webmail successfully. The following morning, we found a sub-set of users with the issue described above.
I found an article describing steps to take resolve this issue:
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_2300-Outlook-continually-prompting-for-username-and-password.html
 I tried the steps to enable kernel-mode authentication, which did not resolve it.
Creating a new email profile for a user did not resolve.
Adding an A-record in DNS autodiscover.icgtax.com did not resolve.
Downloading a new OAB did not resolve.

0
jn2112
Asked:
jn2112
  • 8
  • 7
1 Solution
 
Alan HardistyCo-OwnerCommented:
Why no SP1 for Exchange?  That's the first place I would start.

SP2 was also just released, although I wouldn't rush to be installing that just yet.
0
 
jn2112Author Commented:
I don't think there's a reason that wasn't done, other than the guy being overworked who normally does this. We can get it done. I assume we need to do that before taking further troubleshooting steps.
0
 
Alan HardistyCo-OwnerCommented:
1st rule with anything Microsoft - update!

Yes - please install that first and then if that doesn't resolve your issues - then start troubleshooting.

It will take a good hour to update and the store will be offline for most of that time, so please schedule that for when the least impact on users is going to be, if there is such a time :)

Thanks

Alan
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
jn2112Author Commented:
I have been corrected by my network admin. Microsoft Exchange does not show service packs installed. Instead they use version numbers, apparently.

We have Version: 14.01.0323.003 SP1
0
 
Alan HardistyCo-OwnerCommented:
Okay - then you should be fine.

Please can you check your default IIS permissions:

http://busbar.blogspot.com/2010/05/exchange-20102007-virtual-directory_16.html
0
 
jn2112Author Commented:
According to the link, since Anonymous Authentication is enabled, the Autodiscover virtual directory should have a permission object for : Authentication Users
(read, Read and Execute)

I don't see an entry for that and when I tried to add it, I don't find an AD  user or group by that name.  Otherwise, SYSTEM and Administrators are correct.  
AutodiscoverPermissions.png
0
 
Alan HardistyCo-OwnerCommented:
Should be Authenticated Users.  Needs to be there - it is there on my Exch 2010 server.

I have Read & Execute / Read / List Contents for Authenticated Users
0
 
Alan HardistyCo-OwnerCommented:
I'll also let him know his blog is wrong as Authentication Users should read Authenticated Users (and he is an Exchange MVP!)
0
 
jn2112Author Commented:
Ah.  There seems to be several I have that are not correct, or missing. Should I go through adding and correcting, or would you rather I report the current state before changes?
0
 
Alan HardistyCo-OwnerCommented:
Note down the current settings - in case you want / need to put them back and then set them as per the article and then run iisreset.

If you need to change things back, then you can refer to your notes.
0
 
jn2112Author Commented:
Okay, good point.  Biggest issue seems several are missing Authenticated User entries.  All others appear to be there and set as the site says they should be. I'll document before/after changes as I go through them, in case I need to roll back.  Then reset IIS.

One note: I do not see the virtual directory EAS at all.
0
 
Alan HardistyCo-OwnerCommented:
Translates to Microsoft-Server-Activesync VD.

That's what you get when you have someone who knows Exchange very well - they start using Acronyms and confuse people and shouldn't.
0
 
jn2112Author Commented:
Ah, thank you. I have completed the corrections and reset IIS.  Contacted one user known to have the issue and had them close and restart Outlook. So far, so good.  I'll give this some time, and check on the others tomorrow morning.  Thank you again for all your help, this is the reason this site is awesome.
0
 
Alan HardistyCo-OwnerCommented:
Sounds good - let's hope it stays that way :)
0
 
jn2112Author Commented:
alanhardisty was very helpful, thorough and responsive. When I hit a few snags, he was able to un-snag me quickly.  The solution solved the issue beautifully. Thanks again to a great forum and its excellent experts!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 8
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now