Lenovo S10

Another Lenovo S10 laptop in computer lab cannot get online. It has full wireless signal but will not open websites using firefox or Internet explorer. Did a TCP/IP Repair, did a winsock reset, but still no luck.

Any idea what would cause this?
Pedicode1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

xcasCommented:
to clarify a bit....

can you get online using a cable?

do you have the latest driver?
0
Pedicode1Author Commented:
not even with a cable, by the way OS is windows 7
0
xcasCommented:
uninstall the drivers for Ethernet and wireless...
download the drivers from Lenovo...  
and believe or not... you also need the power-management driver...
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Pedicode1Author Commented:
Update the drivers for wireless NIC?
In Device Manager, It says Broadcom 802.11g Network Adapter  - do you want me to "Update" the dirver

Also how do I  remove/replace the Ethernet dirver?
0
skaraiCommented:
do you get a response to a simple ping e.g. ping www.yahoo.com? Can you ping anything inside your network? outside your network? Cany another machine on the same wireless network get out?
0
xcasCommented:
do not update...  uninstall it

then run the driver downloaded from Lenovo

why do you ask how to remove the Ethernet card driver?  don't you have the option to uninstall it by right clicking on the device?
0
Pedicode1Author Commented:
xcas,

the driver at Lenovo website is the same version as the one currently installed on the netbook which is 5.30.18.0 2009-11-03  - do I replaced this same version?

skarai,

cannot ping www.yahoo.com, but success when pinging 4.2.2.2
0
Pedicode1Author Commented:
xcas:
I uninstalled Broadcom 802.11g Network Adapter driver and Broadcom NetLink (TM) Fast Ethernet driver.

Downloaded Broadcom Wireless Lan driver and installed it.

The driver date now shows 10/1/2008 and version is 4.176.75.21
I successfully setup the wireless which shows a full signal (five bars). Tried IE and Firefox with no luck.
0
skaraiCommented:
can you ping anything else by name? What DNS server are you using? Did you already run ipconfig /flushdns ? DO these machines have custom host files?
0
Pedicode1Author Commented:
When pinging anything by name, it shows "Ping request could not find host www.anything.com. Please check the name and try again.

Custom host files not sure but the host file I found are
C\Windows\System32\drivers\etc\hosts
C\Windows\System32\drivers\etc\lmhosts.sam

Ran ipconfig/all
done the /flushdn
shows Successfully flushed the DNS Resolver Cache.

Not sure where to find DNS server information. Primary Dns Suffic..... sdcs.local
0
XLITSCommented:
Open Network and sharing
-choose change adapter settings
-Right Click on your wireless connection and choose properties
-Double click on Internet Protocol Version 4
-Click on Use the following DNS server addresses
-Enter 8.8.8.8 (this is google's public DNS server)

This is a good way to determine if you have DNS issues.
0
Pedicode1Author Commented:
Did the above and manually set preferred DNS server address to 8.8.8.8

Tried a website but no luck.
0
xcasCommented:
let's try a few things....

one question...   are you getting a "real" IP or are you getting a 169.254.x.x IP ?

can you ping 127.0.0.1 ?

can you ping 209.85.229.104 or 65.55.206.203  (google.com and msn.com) to discard

type this in a CMD...  netsh interface ip delete arpcache

let me know how it goes...





0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Pedicode1Author Commented:
Will reinstall Operating System. Might be the best solution.
0
Pedicode1Author Commented:
Thanks for your help, started OS reinstallation.
0
xcasCommented:
let me know if you still have the same problem after reinstalling
0
Pedicode1Author Commented:
reinstalling the windows 7 fixed the problem
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.