• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1568
  • Last Modified:

Migrating from SBS 2003 to Server 2008 R2 DC

Hi Guys,

Over the past few weeks we have been migrating from our old SBS 2003 server DC to a new 2008 R2 server DC and we have just moved over the roles and tried to dcpromo the SBS server. When we try dcpromo we recieve the following error.

We have been following this guide: http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_2881-Migrate-Small-Business-Server-2003-to-Exchange-2010-and-Windows-2008-R2.html?sfQueryTermInfo=1+10+2003+2008+30+migrat

'The box indicating that this is the last domain controller for the domain is unchecked. However, no other Active Directory domain controllers for that domain can be contacted.
Do you wish to proceed anyway?
If you click Yes, any Active Directory changes that have been made on this domain controller will be lost'

Any help on this would be greatly appreciated.
0
YellowbusTeam
Asked:
YellowbusTeam
2 Solutions
 
Gary ColtharpSr. Systems EngineerCommented:
You should have the new DC listed in the DNS servers of the SBS box
0
 
YellowbusTeamAuthor Commented:
Yes it is listed in the DNS of the SBS server as a host A and also a name server pointing to its IP...
0
 
Gary ColtharpSr. Systems EngineerCommented:
no...not DNS zones... I mean on the network adapter
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
YellowbusTeamAuthor Commented:
have changed the DNS on the adapter...

i now recieve this at the end of the dcpromo on the SBS
The operation failed because:

A domain controller could not be contacted for the domain ybdom1.local that contained an account for this computer.
Make the computer a member of a workgroup then rejoin the domain before retrying the promotion.


"The specified domain either does not exist or could not be contacted."
0
 
Darius GhassemCommented:
Because the SBS server wants to be the master role holder.

Did you seize the roles of this server?

0
 
nsgjohnCommented:
Have you looked to see if the SBS server has already been deleted from the Domain on your new DC?  It sounds like the Domain thinks the SBS server computer is already removed from the domain.  If that is the case when the SBS server attempts to remove itself it will get that error.  If the computer account is already gone in AD you'll want to go through the steps of manually removing a DC through FSMO Metadata cleanup and ADSI.  Then delete all the entries out of DNS etc.

My guess is, since you didn't have the DNS pointed properly it sent the command correctly to the domain but did not recieve a response it was expecting and so never removed AD from itself.  If you are at all familiar with a Swing migration, the step you will want to go through is similar to the steps in the first swing off of the original SBS box.
0
 
YellowbusTeamAuthor Commented:
We have transfered the roles over as per the steps in the article above...

I am not familiar with the swing option, if you have any detaisl / instructions on how to do this then i would be willing to give it ago??

Ta
0
 
YellowbusTeamAuthor Commented:
'Have you looked to see if the SBS server has already been deleted from the Domain on your new DC?  It sounds like the Domain thinks the SBS server computer is already removed from the domain.' The SBS server is still present in AD under the DC group...
0
 
YellowbusTeamAuthor Commented:
Hi Guys,

We resolved this issue with the help from Microsoft support call, thanks for all your help...
below is what resolved the issue for any one having further issues.

>> Tried to run dcpromo down however got an error message that it is unable to contact any other domain controller
>> Ran Dcpromo /forceremoval
>> Successfully able to remove active directory from SBS
>> Remote desktop into Windows 2008 server
>> Verified that all FSMO roles are on 2008 server.
>> Opened Adsiedit.msc
>> Navigated to Default Naming context >Domain> Domain controller
>> Removed SBS domain controller folder and all subfolders
>> Opened DNS console and removed all SBS2003 DNS entries from DNS
>> Opened Active directory sites and services
>> Removed SBS 2003 NTDS objects
>> Stopped File replication service
>> Opened registry editor
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\NtFrs\Parameters\Cumulative Replica Sets\8ca26aac-0162-4f09-85b45fc464489ab2

>> Changed the value of Burflag to d2 to reinitialize replication
>> Started File replication service and successfully able to reinitialize replication.

Cheers Guys.
0
 
YellowbusTeamAuthor Commented:
We have selected our own comment due to it being part of the full solution to fixing the issue
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Tackle projects and never again get stuck behind a technical roadblock.
Join Now