vSphere5

Apple Rubber
Apple Rubber used Ask the Experts™
on
vSphere5 not getting a proper IP address from dhcp.  Getting a 169.254 address.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2010

Commented:
Is it your host you're referring to? Is a network cable plugged into the adapter?
Apple RubberIT Man

Author

Commented:
No, a newly created VM does not receive a proper IP. The host is working correctly
Top Expert 2010

Commented:
Ok; is VMware Tools installed in the VM? Is a VM Network Port Group created on the vSwitch? Is the VM's ethernet adapter (rt-click on VM -> Edit Settings, Hardware tab, Ethernet Adapter) set to the network label/name of the vSwitch VM Network port (drop-down list in the VM settings)? Is the VM's ethernet adapter configured to be 'Connected' and 'Connect at Power on'?

~coolsport00
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Apple RubberIT Man

Author

Commented:
If I configure the IP staticly on the VM It will communicate correctly.  It will only get a proper dynamic address if I change the active adapter order in NIC teaming on the management network of the vSwitch.  Once I reboot the VM it comes back with the 169.254.x.x network, not the proper network.  Also i get this error after i change the adapter order.
Call "HostNetworkSystem.UpdatePortGroup" for object "networkSystem-18" on vCenter Server "CEMVSPHEREP01.apple.local" failed.
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:
could you upload a screenshot of your vSwitch?

do you have two NICs connected to it?
Apple RubberIT Man

Author

Commented:
yes 2 NIC's. screenshot uploaded vswitch
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017
Commented:
are these trunked on the switch?

how have you got load balancing setup up?

are both ports live?
Apple RubberIT Man

Author

Commented:
not trunked on the switch.

See attachment

Both ports are live teaming teaming
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:
If you drop vmnic4 does it work?
Apple RubberIT Man

Author

Commented:
no, it doesn't work with it removed
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:
okay, so if you swap and add vmnic4, but remove vmnic0.

is the host esx server still contactable when vmnic4 removed?

you do not havr any Tag specified on the network portgroup
.
IT Man
Commented:
I set the ports to trunked on the switch and it is working now.
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:
okay load balancing was wrong for switch.
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:
which was what I was trying to get you to establish by dropping nics in your team, glad your fixed.
Apple RubberIT Man

Author

Commented:
no, the physical switch ports needed to be trunk ports
Apple RubberIT Man

Author

Commented:
Thanks for all the help
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:
that is correct which is why I asked previously!!!
Apple RubberIT Man

Author

Commented:
Resolution was setting the hardware switch pot to trunked

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial