Opening Ports

Had to turn on my firewall on a Windows XP machine.  Now I can map drives to the machine with the firewall runed on.  What ports need to be opened in order to map drives?
PeterSchenkAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

flubbsterCommented:
Typically, TCP ports 135, 139 and 445 along with UDP port 137
0
ToxaconCommented:
TCP/445 should be enough for mapping. Naturally, you'll need DNS (TCP/53 + UDP/53) to resolve a server name to map to in a domain environment. If the computer is at home (and you don't have a domain), do as @flubbster suggested.
0
PeterSchenkAuthor Commented:
Open all those ports already and still can map via \\computer name\share
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

ToxaconCommented:
Um, let's refine your question... You do not want to be able to map drives to your XP? If so, just close port TCP/445.
0
PeterSchenkAuthor Commented:
I want to be able to map drive to my windows XP.
0
ToxaconCommented:
The drive mapping itself (SMB/CIFS) uses the TCP/445. You can try it by using the IP address to map the drive: \\aaa.bbb.ccc.ddd\share

Can you ping your XP if the firewall is on?
0
techzterCommented:
I we are understanding you properly you have a Windows XP machine that you enabled the firewall on. You now are trying to share files from this Windows XP machine to other computer on the network. Is that correct?

If that is the case you shouldn't need to manually create any firewall exceptions. Go into the control panel, Network Connections. Select the connection that you want to share the files on, right click  and select properties. Look for 'File and Print Sharing for Microsoft Networks'. Make sure to put a check mark next to that in order to allow sharing of files from the computer.

This will allow share files from your computer and automatically put the exceptions you need into the firewall for you.
0
PeterSchenkAuthor Commented:
techzter,
Tried out your idea..... still does not work by Computer Name or Ip Address.
0
techzterCommented:
Do you receive some sort of error message?

To be clear you did the steps that I had suggested on the machine that you are sharing the from, and not the machine that you are connecting with. Was the file and print sharing not selected before hand? Did the error message change after you had checked it off?
0
PeterSchenkAuthor Commented:
That is correct I followed your instructions to the letter.... Also when I tried to add the ports above Windows said they were already in use.
0
techzterCommented:
I am thinking that this may be a bit more involved that just your windows firewall. Have you tried to disable your windows firewall for a moment? If you do that are you able to connect?

Can you give some more information as to how the machines are connected? For instance are they connected to ports within the same swtich?

Are you able to ping between the machines?
0
PeterSchenkAuthor Commented:
If the firewall is down everything works as advertised.  Pinging and mapping drives to the machine work fine.

Once the firewall comes up you can ping... but not map any drives.

They are on different lan subnets.
0
techzterCommented:
Well that at least gives us hope that this is only a firewall configuration issue. Let's try this. Go into your windows firewall settings. Go into the advanced tab, and restore defaults. This will help eliminate the chance of a manual entry being made that is causing the firewall access to fail.

After restoring the defaults double check and make sure that it has not removed the access rights for file and print sharing. If so put the check mark back in to enable that access again.
0
PeterSchenkAuthor Commented:
Ok restored the default settings and recheck file and print sharing like you suggested.  Still cant map a drive but I can ping the machine by name though.
0
techzterCommented:
Making some progress. So you can ping the machine by name. How about if you go to the run menu and type \\computername or \\ip.address. That should show all of the shares available on the computer. Do either of those connect? If not do you get an error message? If so what is the error?
0
PeterSchenkAuthor Commented:
In both cases the same error comes up "Un able to connect to host"
0
PeterSchenkAuthor Commented:
Strange issue.... not sure whats up... maybe will have the networking guys put a sniffer on it.
0
techzterCommented:
Check this setting. I think it could be the cause. Go into your windows firewall. Select the file and print sharing rule under exceptions, select edit. In the lower left select change scope. I think that by default Windows creates the rule to only allow access to My Network (subnet) only. You mentioned that these computers were on different subnets. Try to change the radial to Any computer and see if that solves the issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PeterSchenkAuthor Commented:
That did it.... Thank you very much
0
techzterCommented:
Woohoo! Glad to hear that it helped.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.