LACP (intel GB VT QuadPort) incombination with PC5548 not working?

Hello,

I have a poweredge 2950, a poweredge 1950 and a powerconnect 5548.
I want to connect both server to each other through the server with max bandwith possibility`s.
So i created a team on all servers and switches.

The PE1950 has 2 broadcom adapters which perfectly work with lacp and the powerconnect 5548. The traffic is nicely loadbalanced over both adapters.

But the PE2950 with the intel GB VT Quad Port Server Adapter doesnt work.
I created a LAG: IEEE 802.3AD Dynamic Link Aggregation.
But for some reason i never get more speed then one GB. Beside that all traffic incoming traffic is going over 1 adapter and the outgoing over another one.
What am i doing wrong.. (port-group 3 is the problem one)

Switch config:

port jumbo-frame
vlan database
vlan 124,500-501,3902,3904
exit
interface vlan 500
private-vlan primary
exit
interface vlan 501
private-vlan isolated
exit
voice vlan oui-table add 000181 Nortel__________________
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 001049 Shoretel________________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00907a Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
iscsi target port 860 address 0.0.0.0
iscsi target port 3260 address 0.0.0.0
iscsi target port 9876 address 0.0.0.0
iscsi target port 20002 address 0.0.0.0
iscsi target port 20003 address 0.0.0.0
iscsi target port 25555 address 0.0.0.0
ip access-list extended "Backup traffic"
exit
username xxxxxxxx password encrypted
username xxxxxxxx password encrypted
 privilege 15
!
interface vlan 124
 name "asdfasdf"
!
interface vlan 500
 name Backup_server
 private-vlan association add 501
!
interface vlan 501
 name Backup_client
!
interface vlan 3902
 name "VC MGMT"
 ip address xxxxxxxxxxxxxxxxx
!
interface vlan 3904
 name "VC MGMT DMZ"
!
interface gigabitethernet1/0/1
 channel-group 1 mode auto
!
interface gigabitethernet1/0/2
 channel-group 1 mode auto
!
interface gigabitethernet1/0/3
 channel-group 2 mode auto
!
interface gigabitethernet1/0/4
 channel-group 2 mode auto
!
interface gigabitethernet1/0/5
 spanning-tree cost 2000000
 channel-group 3 mode auto
!
interface gigabitethernet1/0/6
 spanning-tree cost 2000000
 channel-group 3 mode auto
!
interface Port-channel1
 spanning-tree portfast
 spanning-tree cost 20000
 switchport mode general
 switchport general allowed vlan add 124,500-501,3902,3904 tagged
 switchport general ingress-filtering disable
 switchport trunk native vlan none
 switchport trunk allowed vlan remove 500-501
!
interface Port-channel2
 switchport mode private-vlan promiscuous
 switchport general allowed vlan add 500-501 tagged
 switchport access vlan 124
 switchport private-vlan mapping 500 add 501
!
interface Port-channel3
 switchport mode private-vlan host
 switchport private-vlan host-association 500 501
!

Default settings:
Service tag:
 
SW version 4.0.1.0 (date  12-Apr-2011 time  17:40:25)
 
Gigabit Ethernet Ports
=============================
no shutdown
speed 1000
duplex full
negotiation
flow-control on
mdix auto
no back-pressure
 
interface vlan 1
interface port-channel 1 - 32
 
spanning-tree
spanning-tree mode RSTP
 
qos basic
qos trust cos
eee enable
console#
Hans de JonghAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rm-entCommented:
What OS are your running on the server and what software are you using to team the NIC's?

PO 3 is also missing a mode it needs to be a access or a trunk based on what you are doing with the server.

On PO1 you have "switchport mode general"
On PO2 you have "switchport mode access vlan 124"
On PO3 you don't have anything.

0
Hans de JonghAuthor Commented:
it has pvlan access. which should be enough..
0
Hans de JonghAuthor Commented:
stopped working with the intel cards..
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Hans de JonghAuthor Commented:
problem solved due to different nics.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.