Exchange 2010 Migration with Legacy Exchange 2007

Currently I am in the process of migrating from Exchange 2007 to Exchange 2010.  I plan on running with the 2007 server operation for a bit and believe I am almost to the end of my migration, however the last phases for me are 2 part; CAS Switch and then Mailflow Switch.

I have a few stumbling points that I want to clear up .
Exchange 2007 Environment
DMZ
1 Exchange 2007 Edge Transport Server
Internal
1 Exchange 2007 Server

Exchange 2010 Environment:
DMZ
2 Barracuda 340 Load Balancers
2 Exchange 2010 SP1 Edge Transport servers

Internal
2 Barracuda 340 Load Balancers w/SSL Offloading enabled
2 Exchange 2010 SP1 CAS/HUB/MB servers

I have created the certificate with our email domain and all subject alternative names, as well as created the internal DNS record for legacy.domain.com and pointed that at our 2007 Exchange Server.
I have named the cas array cas.domain.com and put the DNS records in place for that.

I am to the point now that I have actually moved my mailbox to the Exchange 2010 server and if I set it up to go directly to one of the CAS/HUB/MB servers it works perfectly, however if I leave it to resolve to the Cas.domain.com it will not connect.  In Outlook the settings coming in showing cas.domain.com and bmalarkie@domain.com shows up in the adddress field, however it will not continue from that point (sorry, I don't have the error message).

Should this work at this point, or do I have to take that leap of faith that everything is working and go in and perform my CAS Switch?  (IE:  Update 2007 with my new cert and update all my External Facing URL's to legacy.domain.com)

Just as a side note, I have worked directly with Barracuda to make sure the Load Balancers are configured and working correctly.
malarkieAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jessie Gill, CISSPTechnical ArchitectCommented:
If you set your hostname and directly connected to the CAS and you connected to the mailbox fine, then the issue is not an issue with your CAS since auto discover is working.

The issue seems to be when you try to connect to the CAS using the DNS name that is front need by the load balancers.  I also use Hardware load balancing with SSL offload.  have you done the procedure to configure exchange SSL offload?  please look at the link below.


http://social.technet.microsoft.com/wiki/contents/articles/how-to-configure-ssl-offloading-in-exchange-2010.aspx
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
malarkieAuthor Commented:
Yes, I have done that.  
I will walk through the steps one more time to be sure I didn't get something wrong.
0
Jessie Gill, CISSPTechnical ArchitectCommented:
when you test auto discover settings from outlook what do you get?  hold ctrl and right click the outlook icon is the system tray and more options come up.  Also turn on diagnostic logging and post the info here so we can get deeper into it.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

malarkieAuthor Commented:
Ok, so here is what I did in my testing since I have moved my mailbox over;
On my desktop I have gone in and created a new profile and Auto Account Create picks up my Name and Email Account, if I say "next", configuring goes through correctly and I get all green checkmarks.  I click finish, then I go to my Outlook and open (It hang for some time at "loading profile", and choose the profile i just created and the error message I get is as follows; "Cannot open your default e-mail folders.  You must connect to exchange with the current profile before you can syncronize your folders with your Outlook data file (.ost)".  If I connect to a profile that I have used in the past it just tells me "the server is unavailable".  
If I go into my host file and set cas.domain.com to one of my email servers, removing the Load Balancers from the mix, the profiles open up without issues.  
I spent the better part of Friday on the phone with Barracuda making sure that all my settings are correct, so I am sure it is not them.   Add New Account Account Settings
0
Jessie Gill, CISSPTechnical ArchitectCommented:
The only thing I can think of is the ports outlook uses to connect to mail.  Can you bring up a connection status when you open up outlook, it will let us know which connections succeeded and failed.  To do that hold CTRL and right click the outlook icon it he system tray and option for connection status should come up
0
malarkieAuthor Commented:
So Jessiepak,
The issue ended up being on Barracuda's side.  They had me install an early release of the firmware and that seems to have fixed my issue and all mail is traversing my NLB now.

thanks for your help.
0
malarkieAuthor Commented:
The issue ended up being on my load balancers and the answer was correct in Jessiepak's first response.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.