Error Message when sending email to Distribution List

Hello,

One of our user is sending email to distribution list and she is also a part of distribution list. Everyone in the list recieve this email and she can see in her sent items that the email has been sent, but she recieve a message in her inbox which is:

Theres a problem with the recipients mailbox. Please try resending the message. If the problem continues, please contact your helpdesk.

I am clueless what should i check, should i try removing the cache mode as they are desktop users.
Please advise as your help is needed
novice1980Asked:
Who is Participating?
 
mumbaiexpertsCommented:
Kindly check the way may be resolve your issue.
http://www.techieshelp.com/cannot-email-mail-enabled-folders-after-exchange-2010-upgrade/

Otherwise please check  eventviewer and find 9667is occur.
0
 
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
did you check that is all address in the Distrubtion list are in the correct form? its possible some wrong with email on the list , like wrong email address or wrong format
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
novice1980Author Commented:
User advised that the list was working fine but somehow stops working a month ago. I am not sure may be it has to do something with our Migration from Exchange 2003 to Exchange 2010 as we completed Migration a month ago

Any ideas guys.
0
 
novice1980Author Commented:
Below is the error log which we are getting when trying to send email to this Distribution List:

Delivery has failed to these recipients or groups:

There's a problem with the recipient's mailbox. Please try resending the message. If the problem continues, please contact your helpdesk.

Diagnostic information for administrators:

Generating server: EXCAHU2.test.org

IMCEAEX-_O=Test _OU=TEST_cn=Recipients_cn=Where @test.org
#550 5.2.0 RESOLVER.ADR.BadPrimary; recipient primary SMTP address is missing or invalid ##

Original message headers:

Received: from EXCAHU2.test.org ([fe80::45c0:60a4:9bd9:8c6b]) by
EXCAHU2.test.org ([fe80::f028:6253:448f:d169%10]) with mapi id
14.01.0339.001; Wed, 14 Dec 2011 13:29:43 +0600
Content-Type: application/ms-tnef; name="winmail.dat"
Content-Transfer-Encoding: binary
From: JUSTIN <RJUSTIN@test.org>
To: Where < Where@test.org>
Subject: Test email
Thread-Topic: Test email
Thread-Index: AQHMuktK+4q0fro47U6W9Ofy9XJOKQ==
Date: Wed, 14 Dec 2011 13:29:42 +0600
Message-ID: <1EBB0913FB5DA8449CD03B8BFF126B8C09836029@EMBX2.test.org>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator: <1EBB0913FB5DA8449CD03B8BFF126B8C09836029@ EMBX2.test.org > 
MIME-Version: 1.0
X-Originating-IP: [192.168.3.100]

For company's privacy i have channged the name of servers as well as OU and domain n

[Edited by SouthMod]
0
 
novice1980Author Commented:
I've requested that this question be deleted for the following reason:

Issue pending
0
 
novice1980Author Commented:
Just delete questions
0
 
novice1980Author Commented:
I've requested that this question be closed as follows:

Accepted answer: 250 points for junaidIT's comment http:/Q_27488136.html#37269110
Assisted answer: 250 points for mumbaiexperts's comment http:/Q_27488136.html#37269554
Assisted answer: 0 points for novice1980's comment http:/Q_27488136.html#37286560

for the following reason:

as i solved 50% by myself
0
 
novice1980Author Commented:
ok
0
 
novice1980Author Commented:
I've requested that this question be deleted for the following reason:

Issues is now resloved
0
 
novice1980Author Commented:
Ok
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.