Problem with eclipse / IBM RAD IDE with exit code 8096, JVM termiated.

Hi there;

When it comes to swing programming in IBM RAD based on eclipse, sometimes, I end up with this screen (more than sometimes in fact).

What to do? I followed the steps to change eclipse.ini in the given path but no avail.

Please note that, my windows 7 scheme turns to Windows Basic that the taskbar becomes light blue.

Kind regards.
eclipseissue.png
LVL 12
jazzIIIloveAsked:
Who is Participating?
 
for_yanCommented:

this seesm to be more relevant:
http://wisteme.com/question.view?targetAction=viewQuestionTab&id=5198

Try one of the following solutions if increasing heap size to 1024 (modifying -Xmx786m to -Xmx1024m in eclipse.ini), reboot machine or switching to another Java 5(modifying -vm in eclipse.ini) doesn't help.

Destroying the corrupt java cache solved the problem.

        On Microsoft® Windows®:     javaw.exe -Xshareclasses:destroy

        On Linux®:     ./javaw -Xshareclasses:destroy  

    Here is the IBM webpage which contains the detailed information.

    Rational Software Development Platform desktop product fails to launch
0
 
for_yanCommented:


did you check this (though it is something about Lotus, but who knows - could help):
http://www-10.lotus.com/ldd/nd8forum.nsf/0/4a82ec5218a533168525754d0042a9a6?OpenDocument

SOLUTION: Delete all files in the Windows temporary folder (e.g. C:\Documents and Settings\<user>\Local Settings\Temp). Apologies that I did not determine which ..\Temp folder/file you have to remove to solve the 8096 error.
0
 
jazzIIIloveAuthor Commented:
for_yan:
For the first comment, deleting temp that I had tried didn't help.
For the second comment, yes, i had tried no use.

The eclipse.ini that I am using as follows:

-vm
C:\Program Files (x86)\IBM\SDP70\jdk\jre\bin\javaw.exe
-vmargs
-Xquickstart
-Xgcpolicy:gencon
-Xscmx96m
-Xshareclasses:singleJVM,keep
-Xnolinenumbers
-XX:MaxPermSize=512M
-Dsun.java2d.d3d=false
-Dsun.java2d.noddraw=true
-Xmx256m
-Xms256m

original eclipse ini that i was using:

-vm
C:\Program Files (x86)\IBM\SDP70\jdk\jre\bin\javaw.exe
-vmargs
-Xquickstart
-Xms40m
-Xmx768m
-Xgcpolicy:gencon
-Xscmx96m
-Xshareclasses:singleJVM,keep
-Xnolinenumbers
-XX:MaxPermSize=512M



Kind regards.
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
for_yanCommented:
Maybe you don't have suficient memory?
Your original had -Xmx768m
and you are using only -Xmx256m

As you see, some folks saw fixing this problem with increasing memory
0
 
jazzIIIloveAuthor Commented:
6 G is the memory of my machine, any ideas for the value?

Kind regards.
0
 
for_yanCommented:
on a 64bit machine, put, let's say, 4000M
I know on 32 bit about 1500M is maximum,
dn't know what can be the limit on 64bit,
but you can put even bigger numbers than maximum, it will not complain
0
 
jazzIIIloveAuthor Commented:
but to which line is the question?

Kind regards.
0
 
for_yanCommented:
change this

-Xmx256m

to

-Xmx4000m



0
 
jazzIIIloveAuthor Commented:
btw, since the color scheme of my windows 7 changes, I also added the lines regarding direct3d as in my ini. Is it OK?

Kind regards.
0
 
for_yanCommented:
I'm not sure what is direct3d.
Don't think it is likely that it causes the error.
But if the addition of direct3d has some time correlation with occurrence of these errors, then obviously you should consider removing it.
Otherwise, I don't think it is probable that it matters.
Still in order to diagnose such intermittent problem, it is better to stick first to the default ini and yhen introduce stepwise deviaions
from the default so that you could catch the change which may have caused instability.
0
 
Sharon SethCommented:
Your windows color scheme defaults to Windows basic since your original ini had direct3d and ddraw(direct draw) disabled . Enable both by changing the values to true and false respectively . This should retain your color scheme .

For increasing  memory vailable to the VM , I normally do this : http://www.eclipsezone.com/eclipse/forums/t61618.html
Since u want to use Direct3D , you may want to give the VM more space than usual.
0
 
jazzIIIloveAuthor Commented:
-Xmx4000m
gives the error, as the ide is not even starting.
0
 
for_yanCommented:
well, reduce it to the point when it will start.
It sounds strange to me - it usually does not complain on high numbers in this parameter.
Maybe it does not start because of some other reason?
Make it  -Xmx1500m
If that does not work make it -Xmx1200m - this I think should work even on 32 bit machine
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.