USB wireless adapters no longer recognized

Wireless Cards Not Being Recognized by networking
I have two separate Wireless network adapters that I have tested against this Windows 7 home-built PC. Neither are working: after inserting the USB device, using device manager to add the correct (latest) Win 7 x64 drivers and installing the drivers successfully, Windows is still posting "problems" with the USB wireless devices. Troubleshooter is saying there may be a problem with the driver. I have reinstalled Windows, tried the devices in any of the 10 USB ports on my computer and have had no success. Proprietary connection software that comes with the devices fail to recognize the devices, though in Device Manager, they appear correctly, no exclamation mark or anything.

Networking was fine until graphics card failure
I've had this P55-Sli based PC working for over a year, with one of the network adapters in question. Worked great, ran a little hot. I left it running for about a week for a really long download and when I came back to it, the graphics card was fried. Computer wouldn't post. Replaced the graphics card and bought a new wireless card since the other one was a little flaky (I often had to unplug it and plug it back in after a reboot so the computer would recognize it).

Driver installation hangs until device is unplugged
After installing the new graphics card with no problems, I attempted to install the new wireless adapter (a D-Link DWA125 Rev A2). Strange thing was that every time I have tried to install the driver for this device, the process completely stalls... until I unplug the device and then it finishes up. In other words the progress bar advances to a point and then just doesn't advance, even for an hour, until the instant I unplug the device and then it instantly finishes up.

Windows reports error with driver software
Note that this is not the case the with other adapter - the Netgear WGT111. That adapter installs just fine, and, like the D-Link, after installation, I can see it in the Device Manager, correctly identified, no exclamation marks. It's just that Windows just doesn't do anything with it and when I try to use the Windows 7 troubleshooter all it reports is "there appears to be a problem with the driver for this device." I get the same message from the troubleshooter with the D-Link device as well.
LVL 14
tomaugerdotcomAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

getzjdCommented:
Curious.. does the LAN card work ok?
0
David Johnson, CD, MVPOwnerCommented:
Question now is what else fried.. I'm guessing you didn't overclock your graphics card and play an intensive game for the entire week.

When you say hot, do you mean too hot to touch, uncomforably hot, or on the hot side of warm.. Scientists have actually determined the ranges of heat this way.
So I'm thinking power or memory.. Do you monitor your cpu temperatures? Try running memtest overnight and see what the results are.. (graphics cards are tied almost directly to the memory bus)

Any other devices in device manager showing problems? do other usb devices work properly?

I leave my machines on 24/7 and am processing a lot of external data (lots of network i/o up/down) and have never had a problem.

0
nobusCommented:
i also suppose something else got damaged - but test your cards first on another PC (wireless and other) to be sure they are OK or not
also - are you sure the power supply can handle the load?   calculate what you need here : http://extreme.outervision.com/PSUEngine      

sinc eyou fried parts, install speedfan to monitor the temps : http://www.almico.com/speedfan.php
0
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

davidlevans13Commented:
I am curious about a couple things.
Why would the graphics card fry if it was just idling away? (what type of case cooling do you have going?)
What type of card was it? Fanless or cooled?
Why are you using USB adapters for your desktop computer instead of a PCI slot adapter?
(I use USB adapters for short term but not as a permanent solution)

Is the power supply good? Any power surges going on?

Like I say, just curious.
( it was mentioned above about checking to see if other USB devices work.. do they?)
0
davidlevans13Commented:
Just remembered...
With the TP-Link adapter I use, you install drivers before you insert device.

Also... did you uninstall old drivers and possible configuration apps from old adapter before installing new adapter?
D-Link suggests uninstalling all other wireless adapter software..
Manual here ( I think)

ftp://ftp.dlink.com/Wireless/dwa125_revA2/Manual/dwa125_revA2_manual_110.zip

0
tomaugerdotcomAuthor Commented:
@getzjd: yes. I tested on another 64 bit Win7 machine and the installation was flawless.
0
tomaugerdotcomAuthor Commented:
@ve3ofa: So I don't have a ton of other USB devices. I have a wireless mouse and keyboard by Logitech with a single Unifying dongle, that appear to still work perfectly. I have been able to hook up an external HDD via USB and that's worked great, backing up over 300Gb without errors. As far as "hot", I have no proof that it was an actual overheating issue - just a theory. I don't measure CPU temps on that PC, and it's too late to do so if that was the problem - the damage has been done and the GPU completely replaced with a different graphics card. The only other device in device manager showing problems is my wired ethernet NIC, which I don't think I've ever bothered to configure, so I doubt that is the problem.
0
tomaugerdotcomAuthor Commented:
@nobus: good suggestion on the power load, but my power supply is way over-specced for what I've got in there. But I will definitely take a look at the power calculator to be 100% sure. I'll get Speedfan on there for the future - I run it on all my other PCs. Of course that won't solve today's issue...
0
tomaugerdotcomAuthor Commented:
@davidlevans13: I'll get to your most relevant question first. Yes, I did uninstall all other drivers first. And yes, I installed the driver before inserting the device, though if you install staright off the CD installer, at one point in the installation process, it asks you to insert the device. I did this at that time, and it continued for a moment, and then just hung. I had to remove the device (after waiting about half an hour) and then it immediately finished up, saying it hadn't completed the installation process, although in device Manager, the device is now registered correctly.

I have uninstalled and reinstalled many times, I have even completely re-installed Windows, to no avail. Neither the new device, nor the old one for that matter are recognized even after the drivers are correctly installed.
0
tomaugerdotcomAuthor Commented:
@davidlevans13: as far as the why the graphics card blew up, I cannot say for sure. Could have been dust buildup (the computer is a family PC that sits near ground level in a pet-infested home). Could have been just a crappy graphics card (Chinese knockoff of the nVidia 9800 GTX). Or maybe there was a power spike at some point which may have fried the GPU. Who knows? At some point I came back to the PC to discover it was no longer on. After that, it wouldn't post.
0
nobusCommented:
also - check the wireless card slots -  maybe  dust or a bent connection ?
0
tomaugerdotcomAuthor Commented:
@nobus: since it's a USB connection and not a PCIe card, reseating and dust are not a big concern. Thanks for the advice - I will be sure to blow out the USB ports, but I doubt this is the issue, as I have tried in all 10 USB ports and all of them exhibit the same behaviour.
0
David Johnson, CD, MVPOwnerCommented:
Well we're pretty much down to a bad motherboard or memory, test the memory with memtest or remove all but 1 stick of ram, reboot, test USB and work your way through the ram.  
0
davidlevans13Commented:
Have you tried running another OS on the machine to test the adapter and motherboard that way.
I have had good luck with the packaged drivers in Ubuntu working with USB adapter (TP-Link G)

http://www.ubuntu.com/download/ubuntu/download

I usually run it off a USB stick, but CD works well.
0
tomaugerdotcomAuthor Commented:
@ve3ofa: Good advice on the RAM, though I haven't experienced any blue screens or other signs of bad mem. What sorts of diagnostics can I run on the motherboard to identify or eliminate that as a potential cause?
0
tomaugerdotcomAuthor Commented:
@davidlevans13: that's an interesting approach. I'll keep that one in my back pocket if motherboard diagnostics prove to be inconclusive.

Does anyone have pointers or recommended software that can help identify a bad USB controller on the motherboard?
0
nobusCommented:
sorry to miss the fact it was USB -  here a list of things to try :
-from Device manager scan for new hardware
-in device manager>view tab, click "show hidden devices" and delete all usb entries and hidden devices,  reboot and test
-then you can download the latest drivers for the chipset, and reinstall it to update the USB root hubs
-start>run>diskmgmt.msc      check if the usb devices show up in disk management, then run :   start>run>services.msc
In the listing look for removable storage service.
If it is set to Auto, and not started, then start it : click the Start link in the top left...
-In c:\windows\inf, look for usbstor.inf    -  If it is not there, you can copy it from another PC..When you find it, right click it and select Install

0
tomaugerdotcomAuthor Commented:
@nobus: I might just be misinterpreting your suggestions, but it sounds like you're getting me to uninstall and reinstall USB storage device drivers. Is that correct? If so, what is your reasoning behind that, as my USB external storage devices seem to be exhibiting no problems?
0
nobusCommented:
it is the best way to have a clean usb section again imo; also showing hidden device s can help you
0
tomaugerdotcomAuthor Commented:
Okay, so far I haven't had anyone address the issue of USB diagnostics on the motherboard. Lots of second-level stuff like dusting the USB ports and cleaning USB drivers. How about some first-level diagnostics on USB. What software or tests should I run to ascertain that it's a USB and not a networking issue?
0
nobusCommented:
>>  What software or tests should I run to ascertain that it's a USB and not a networking issue?   <<  test if you can connect to internet, or other pc's
test if you can connect USB devices : flash stick, external disk, printer..
0
nobusCommented:
for USB , i found this useful :  http://safelyremove.com/?pid=1
0
tomaugerdotcomAuthor Commented:
@nobus: thanks for the link. This looks like a way to safely remove USB devices (hard drives, etc). How is that supposed to help me diagnose a faulty USB controller on the motherboard? Does it have an advanced diagnostic mode?
0
nobusCommented:
did you look on the site?  it lists a number of possibilities
also - if you boot from a Knoppix cd, you can test if you can connect to the net and if the usb works  - so you're sure it is hardware or not : ftp://ftp.gwdg.de/pub/linux/knoppix/KNOPPIX_V6.7.0CD-2011-08-01-EN.iso 
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tomaugerdotcomAuthor Commented:
hi @nobus, thanks for the follow up. The issue is not connecting to the net - though I can certainly try that out with a hard line if you think the test is worthwhile. I will go back to the site and look through it more thoroughly, but didn't see anything that looked like a USB diagnostic or troubleshooting guide.
0
tomaugerdotcomAuthor Commented:
@nobus: I'm quite certain that the safelyremove.com site you pointed me to is ONLY promoting their safe removal software tool. I don't see anything around motherboard / USB diagnostics. Is it possible you sent the wrong link?
0
nobusCommented:
no it is not intended for diagnostics, but has options you can try - and that shows also if it works ok - and it's the correct link
but if you see no use in it, so be it
0
tomaugerdotcomAuthor Commented:
Thanks @nobus for your input. I'll test it and see if it helps.
0
nobusCommented:
you risk nothing - it has a free trial
0
tomaugerdotcomAuthor Commented:
The issue was twofold:
1. The BIOS needed to be updated to the very latest version (older versions had the very bug I was encounterging)
2. The BIOS still has a bug whereby having ANY USB 1.0 devices plugged in (this includes wired mice / keyboards ) would interfere with USB 2.0 NICs

Armed with this knowledge, I did NOT have to replace the Mobo, and the system is now working well.
0
nobusCommented:
tx for feedback
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Desktops

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.