Excel 2007 saving process fails when files are opened over the LAN

Hello

Layout: I am hosting a file server on Linux (Samba), from there users are opening files (edit, create/delete, view) over the LAN.
Scenario: a user is opening an excel file and edits it. When he's asked to save the file and confirms, nothing gets save and a *.tmp file appears instead of the original file.
So far i have notice that:
-it's not user or file related not even location is the same.
-it does not matter if the file is in xls, xlsx or xlsm format.
The common thing:
-all users are using the MS Excel 2007 with SP2.

Any advice? It seems that i'm lost in this issue.

Regards,
Cosmin C.
Cosmin CurticapeanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

raysonleeCommented:
Probably you don't have the rights setup properly.
Try use
force user=myuser
or
force group=mygroup
and make sure the user/group has appropriate rights by:
create mask = 0777
force create mode = 0777
directory mask = 0777
force directory mode = 0777
0
Cosmin CurticapeanAuthor Commented:
Hello

maby I should of have added that this behaviour started after the upgrade to MS Office 2007, samba server had settings done a long time before and had no problem like this. I did check them, now they look like this:

[Directory]
        comment = Common data directory for each department
        path = /usr/XXXXXXX
        browseable = yes
        writeable = yes
        read only = no
        create mask = 0777
        directory mask = 0777
        force directory mode = 0777

I've added the last line, and modified the masks from 777 to 0777 for the other two.
0
raysonleeCommented:
If the problem only occurs on new directories, add
inherit permissions = yes
inherit owner=yes
Check the group, user and access mode of *.tmp files and corresponding folders.
Make sure user root does not have any problem.
Try "force user=root" if the above didn't fix the problem.
Remember to restart samba after changing the configuration file.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SBallayCommented:
Turn Off Auto-Tuning
CMD: netsh int tcp set global autotuninglevel=disabled

Run this on one of the user's laptop/Desktop
See if this works.
0
Cosmin CurticapeanAuthor Commented:
Hello

i will try both solutions, it will take a few days to reveal if any is having succes Please stand by for my answer.

Regards,
Cosmin
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Excel

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.