SP1 blocks port 3389 on windows 7 ultimate

every time i install service pack 1 on windows 7 ultimate i cant remote desktop to the dekstop any more if i do a system restore to before the update everything works fine

after the update i can locally login to the PC and access all files on the network

i can remote out from the PC

i tried to telnet localhost and that seems blocked as well

is there any way to get this working again with out having to do a system restore ?
dpmitsolutionsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dpmitsolutionsAuthor Commented:
yeh but there isnt a fix on the link unless i missed it
0
David Johnson, CD, MVPOwnerCommented:
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

dpmitsolutionsAuthor Commented:
surely there has been a fix for this

i post with microsoft but that can take over day
0
veeraCommented:
Hi,

you can use group policy to execute powershell script and enable the Remote Desktop Rules..

1)create a file that contains following script with extension as ps1..

netsh advfirewall Firewall set rule group="Remote Desktop" new enable=yes

2)create a group policy object and goto startup script ..there you can see powershell Scripts

Note: I did not checked practically ..it's just my idea..that's it
0
dpmitsolutionsAuthor Commented:
Thanks mcaroom but it didnt work

i noticed the service  remote desktop service   is stuck on starting if that helps

i also uninstalled the antivirus same problem
0
IanThCommented:
try using a diffferent port and see if that works
see
http://www.petri.co.il/change_terminal_server_listening_port.htm
I know its about ts but it will work for rdp
0
veeraCommented:
did you applied that policies to computers or users..you must apply that policy to computers only...
0
dpmitsolutionsAuthor Commented:
i ran out of time so i formatted the server it was quicker
0
IanThCommented:
what and that fixed it do you have sp1 installed and rdp working
0
dpmitsolutionsAuthor Commented:
yeh i used a Windows 7 disk with SP1 so i knew it will work
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dpmitsolutionsAuthor Commented:
not the solutions i wanted but it did resolve the issue quicker then further troubleshooting it
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.