Missing menu in SharePoint 2010 but only on a particular PC.

In SharePoint 2010, in my Team Site at the Top Level, there is normally a menu in the top right corner, showing my Name and giving access to My Site, My Profile, My Settings, Sign in as a different User and Sign Off. On my PC this is NOT visible BUT when I log on to the same account on another PC is it IS visible. In either case, if I go to Site Actions and Site Settings the menu is visible. Any ideas on how I can make it visible all the time on my PC? Thanks.
DataTrainAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tapiwabCommented:
i think it might be the browser, which browser are you using ?
was this team site customised using desinger
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DataTrainAuthor Commented:
I am using Windows Internet Explorer 9. The site has been created using SharePoint and not using Designer.
0
DataTrainAuthor Commented:
Any other ideas?
0
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

jessc7Commented:
Are you using the default security zone settings on the PC where you do not see the menu?
0
DataTrainAuthor Commented:
I am using the default Internet Explorer settings. They look similar to the other PC.
0
DataTrainAuthor Commented:
I have tried on another PC and it works fine - it is only my Laptop where I have a problem. The laptop has Fingerprint Authentication and I am wondering of this might have something to do with it?
0
DataTrainAuthor Commented:
I was considering the fingerprint authentication as it is a difference between my PC and the others but I don't see how this could cause a menu to disappear so I am still seeking a solution!
0
jessc7Commented:
Have you verified SharePoint is recognizing it as the same user account when you access it via the PC where it isn't working?
0
DataTrainAuthor Commented:
Yes - it comes up with my name.
0
DataTrainAuthor Commented:
I have just downloaded Mozilla Firefox 8 and it works correctly in that browser. So it must be an issue with Internet Explorer 9.
0
jessc7Commented:
Are the other PCs not using Internet Explorer 9? I have IE9, and am able to see it on a non-SP1 farm.
0
tapiwabCommented:
Normally it is the browser problem IE 64bit browser and 32bit browser work differently at times
0
DataTrainAuthor Commented:
All PCs are using IE9 (same version) 64-bit.
0
jessc7Commented:
IE9 installs both 32-bit and 64-bit on a WIndows 64-bit operating system. Make sure you are testing with the 32-bit version, as the 64-bit version of IE9 is only partially supported. Look for the "Browser support matrix" table:

Plan browser support (SharePoint Server 2010)
http://technet.microsoft.com/en-us/library/cc263526.aspx
0
DataTrainAuthor Commented:
I haven't really got to the bottom of this but I need to close the question. Thanks to everyone who tried to help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.