2007 to 2010 Cross Forest Migration, New-MoveRequest Error

I have followed the MS recommended cross-forest migration process from Exhcange 2007 to 2010. However, after successfully running the Prepare-MoveRequest.ps1 and trying to perform the actual mailbox migration i get the following error:
"Parameter -RemoteTargetDatabase must be specified.

The command i am using, identical to MS's example and similar cases found here:
New-MoveRequest -Identity 'test3@newdomain.com' -RemoteLegacy -TargetDatabase 'Storage Group' -RemoteGlobalCatalog 'dc01.oldDomain.Old.com' -RemoteCredential $RemoteCredentials -TargetDeliveryDomain 'Mailboxserver01.newdomain.com'

Its almost as though its trying to migrate the wrong way (from 2010 to 2007). If i do as it says and change targetdatabase to remotetargetdatabase it give my the obvious 'Source user 'test3' doesn't have a primary mailbox.' which further enforces my theory.
jav-cvmAsked:
Who is Participating?
 
jav-cvmConnect With a Mentor Author Commented:
Success when I created a new test user and did things in the following order:
- Prepare-MoveRequest.ps1
- New-MoveRequest
- ADMT steps

with the problem test user above i had done the following:
- Prepare-MoveRequest.ps1
- ADMT steps
- New-MoveRequest

I believe this was the source of my problems. Any insight as to why?

I checked throughout the ADMT process to ensure no Prepare-MoveRequest.ps1 created Exchange attributes were being overwritten, i could not find any that had been. Only difference I could see was that the user is disabled in during the move in when using the correct process.

I also disabled UAC and rebooted (not the first reboot while experiencing this error), not sure if that had an effect.

Thanks all for your assistance, i am a long time user of EE, first time posting.
 
0
 
Jeff PerryWindows AdministratorCommented:
Have you tried it with the Outbound parameter?

'Outbound
 Required
 System.Management.Automation.SwitchParameter
 The Outbound switch specifies that this mailbox move is a cross-forest move and is being initiated from the source forest. You don't have to specify a value with this parameter.

You can't use this parameter in conjunction with the Remote switch.
 '

Found here http://technet.microsoft.com/en-us/library/dd351123.aspx
0
 
jav-cvmAuthor Commented:
I am initiating from the Target forest with 2010.
0
 
jav-cvmAuthor Commented:
Tried again with a fresh test user and performed the tasks in the MS recommended order. Although i had thought the order arbitrary, it seemed to resolve my problem.
0
 
Jeff PerryWindows AdministratorCommented:
Sorry I couldn't have been more help but glad you got it working.

Without further investigating to understand it better I would guess the order of the steps you mentioned.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.