Strange issue with KVM-over-IP

We have a KVM-over-IP device on our network - Lantronix Spider Duo.

It was working fine for a year or so, then recently we changed some things on our network - new server, an extra gigabit switch, etc. (too many things to isolate which would be the cause) and we can no longer get it to work.

If I connect the KVM directly to a dedicated network card on our server and assign it a static IP, it works fine.  As soon as I connect it to our main LAN - either on a switch or even directly to a router port, it no longer works.

I have reset all the switches (which are D-Link unmanaged units) and also reset the router to factory defaults, but it just won't work.  It is the same router as we had before.  DHCP is turned off and our SBS 2003 server is doing the DHCP.  

If I tell the device to get a dynamic IP address, it comes back that it cannot obtain one.

If I set a static IP (tried at least a dozen different ones), it *looks* ok, but I cannot access it or ping it (destination unavailable).

How is this possible?  Could our SBS server block a MAC address?

Thanks in advance for any ideas!
ahotmailAsked:
Who is Participating?
 
MysidiaConnect With a Mentor Commented:
My suggestion would be to  assign the KVM over IP a static IP address in the same subnet as your LAN.   Assign a laptop a static IP address in the same subnet. Use a cross-over cable to plug the KVM over IP directly into the Laptop

Verify you can ping the KVM over IP; in this configuration.
Verify the subnet mask configured on the laptop and on the KVM match the proper subnet mask for your LAN,  and the IP address assigned to the KVM lies in the same subnet as the laptop and the rest of your LAN.

Get straight-through network cables and plug the laptop and KVM over IP directly into a switch.
Test ping  the KVM's IP address from the laptop.


If no ping response in this configuration,  try testing ping with the Laptop and the KVM over IP being the only devices plugged into the switch -- in other words,  with everything unplugged from the switch except Laptop and KVM.

If even this simplest possible config cannot be made to work (Laptop and KVM, nothing else plugged in), then it seems you have a problem with the cabling or a problem with the switch  -- the KVM working in crossover mode essentially shows the KVM is operable.

You might have an inherent problem with the switch, such as a disagreement between the switch and KVM on  Speed and Duplex.   Generally, the KVM/host device should be set to auto-negotiate speed and duplex. If you need to hard set them,  try  telling the KVM to force the link to   100 Megabits, Half duplex.

For any other forced speed/duplex parameters,  you need to be using a managed switch, so you can force both sides of the link to a certain speed and duplex.
That key step is impossible with an unmanaged switch.

A true CLI managed switch would actually provide some better troubleshooting info.

Should the basic troubleshooting not work, the next step is probably to buy a new switch managed (or unmanaged),  of a different brand/manufacturer/model  (than that fail-happy Dlink er stuff).

The basic troubleshooting method should include swapping cables involved, and trying different ports on the switch.


If you _are_ able to ping and reach the KVM from the laptop when only two devices are plugged into the switch, then plug cables back into the switch one by one until ping to the KVM stops working.


Because your switch is unmanaged, this trial and error technique is the only way to find which port on your switch  the problem  lies downstream of,  if there is a problem being caused downstream, on another port.

Anything from a IP/MAC address conflict  (two different devices on the network trying to use the same MAC address or IP address),  to a network loop,  or misconfigured netmask could be at issue.


Network traffic between different computers on your LAN should not be traversing between routed ports on your router unless you have a multi-VLAN/multiple-subnet design for your LAN.

Between devices on the same LAN segment and same subnet, traffic is only to be switched, not routed.





0
 
IanThCommented:
a server cannot block a mac address thats a router function
0
 
ahotmailAuthor Commented:
Thanks for the info IanTh, that is what I thought....

So any ideas what could be blocking it then, considering I restored the only router on the LAN to factory defaults?

Thanks.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
giltjrCommented:
It works when connected directly to a computer, but not to a switch?  

Although I would assume you have, I have to ask.  Have you tried different cables?

What type of router?

0
 
ahotmailConnect With a Mentor Author Commented:
Mysidia, thanks for the reply.  I ended up setting up a VLAN on our router on a different subnet (192.168.2.X instead of the main subnet of 192.168.0.X) and then plugging the KVM into that port directly and it worked.  If it was on the same subnet as the rest of the network .0.X it just won't work...

Although they are good ideas, I have tried all of your suggestions in the past, such as:

crossover cable direct to KVM from a laptop - it would work
plug them into a switch alone (no other devices on switch) - it would work
plug it into the rest of our network - it stops responding (even though there is no IP address conflict)

The only thing I didn't try is unplugging every cable and plugging them in one by one (we have 96 cables plugged in on a production network, so it would be difficult to test).

Oh well, even though I never found out the root cause, it's at least working now :-)

Thanks.
0
 
ahotmailAuthor Commented:
Thanks for the tips!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.