Cannot Remote Desktop to Server after changing certificate

I am running SBS 2003, standard. I have been using an SSL certificate issued by a CA, which expires next week. I requested a new SSL certificate from another company, which I expect to receive in a few days. In order to request the new certificate, the Certificate wizard required me to remove the old certificate. Now it will not let me reinstall the old certificate without making a new request, which I fear will screw up my ability to install the new certificate. (I may be wrong.) So I ran the Internet setup wizard with a self-signed certificate. Remote Web Workplace works okay (after Internet Explorer complains about the certificate) and I can access my office workstations, but I cannot access my server remotely either directly through RWW or by remote desktop from another workstation inside or outside the office. The error message is:

The remote computer requires that authentication be enabled to connect.
Remote computer: server1
The connection cannot proceed because authentication is not enabled.

An additional new development is that although I can establish a VPN connection to the server without difficulty, once connected I cannot access any of the resources of the office network, not even by pinging.

I have read that terminal services requires an SSL certificate (not self-signed). Is this always true, even for intranet access?

I hope that when I get the new SSL certificate all of these problems will go away. However, I fear there may be something else going on. In the meantime, is there any workaround to get remote access to my server?

Many thanks in advance.
ClapadorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ClapadorAuthor Commented:
SOLUTION: Installing the new certificate did not fix the problem. The culprit was:  Server Management > Advanced Management > Terminal Services Configuration > Connections > RDP-Tcp > Properties > General tab > Security layer : WAS set to RDP Security Layer. I changed it to Negotiate and everything works!

Question: is the new setting a security risk?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.