linksys WRT54G2 web port forwarding

I have a server on my LAN and I want to use my linksys WRT54G2 to forward internet traffic to my CentOS web server where I have my website. I had it working before using NAT one-to-one on my SOHO3 Sonicwall, but the Sonicwall died. I'm trying to just use this Linksys now to route the web traffic for now. I realize it's not optimal, but I think it should be working.

I set Port Range Forwarding to forward port 80 to 192.168.1.43 (my web server).

RDP is working fine to my file server, but the web server just won't work. I can see it locally on my LAN, but when I go to the WAN address in a browser. No can do. linksys port range forward
LVL 1
mrmythAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

akahanCommented:
Have you tried accessing it from outside your local network?  You're generally not going to be able to access an address on your LAN through this router from within your LAN using the WAN address.

Also, make sure remote administration is turned off in the router.


0
mrmythAuthor Commented:
Thanks, good point. I have tried from outside and I have the same problem.

Here is a screenshot of the settings I have for remote administration. I'm not sure the difference between "Web Access" and "Remote router Access." router Remote access
0
akahanCommented:
The settings look right.
I suppose you could try putting the web server in the DMZ temporarily to make sure there's not some firewall blocking access.
0
Get Cisco Certified in IT Security

There’s a high demand for IT security experts and network administrators who can safeguard the data that individuals, corporations, and governments rely on every day. Pursue your B.S. in Network Operations and Security and gain the credentials you need for this high-growth field.

mrmythAuthor Commented:
okay i figured something out. my web server is CentOS and i can't  get the port to forward to it, however, my file server also has an old website on it and i forwarded the 80 web port to it and it works fine, i can see the site from a browser. the external IP address is new, maybe the CentOS sever website requires some change of some sort
0
mrmythAuthor Commented:
By the way, my fle server is windows smb 2003. Ive just requested attention from a Linux queue too in case it's it's a setting on my web server to accept the WAN IP address change
0
Istvan KalmarHead of IT Security Division Commented:
Hi,

the problem is that the router use this ports to mgmt, you need to create another NAT rule for example:

4443 --> 443
8080 --> 80
0
shukalo83Commented:
as root on centos send us output of those

iptables -n -vL
iptables -n -vL -t nat
netstat -tapn
cat /etc/hosts.deny
cat /etc/hosts.allow
ip addr show
ip route show
0
shukalo83Commented:
As for linksys, disable any firewall, disable management from outside.
0
mrmythAuthor Commented:
Can I create a nat rule on this router? How come it works with my windows server?
0
shukalo83Commented:
OK, now I got that you did not made port forward at all.
http://portforward.com/english/routers/port_forwarding/Linksys/WRT54G2/

Do it and then try from outside with your webbrowser. (You enter the wan address of linksys router, no webserver itself)
0
mrmythAuthor Commented:
Shukalo83, look up above at the 1st screenshot. Port forwarding was done. Is that what you were referring to?

0
shukalo83Commented:
Sorry on that again. If your centos is 192.168.1.43 then yes.

Please, can you post me output of aforementioned commands from webserver?
0
akahanCommented:
It's clear that the router settings are fine; problem is with the server setup.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mrmythAuthor Commented:
I think it might be that the old  firewall was at 192.168.1.253 and the new one is at 192.168.1.1

Maybe I'll change the internal ip address of the firewall first before I try to change the web server.
0
mrmythAuthor Commented:
I decided to change the web server instead. Went into the control panel of the server and found that the default gateway was indeed 192.168.1.253. I changed it to 192.168.1.1 and I'm currently rebooting.
0
mrmythAuthor Commented:
Thanks for all your help. It turns out that the default gateway on the web server had to be changed from the address of the old sonicwall 192.168.1.43 to the ip of the Linksys router 192.168.1.1
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.