VS 2010 C# Upgrade from VS 2008 C# GP 10

I am trying to convert my first VS 2008 GP 10 class library to GP 2010 using VS 2010.  The VS 2008 application included these three references.
Application.Dynamics.dll
Microsoft.Dexterity.Bridge.dll
Microsoft.Dexterity.Shell.dll
I have droppped these three references and added them back pointing to the newer GP 2010 versions and the problem I have is that the GP 2010 versions of these dlls appear to be .Net FW 4.0 dependent. I need to deploy my code to WXP computers that will not have .Net FW 4.0 but will have .Net FW 2.0.
Has anyone else come across this?  Can I simply copy the older dlls from GP 10 and use them instead?
LVL 1
rwheeler23Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Steve EndowMicrosoft MVP - Dynamics GPCommented:
Hi,

The VS Tools DLL references should only require .NET 2.0.  I believe what you might be seeing is the Visual Studio 2010 project defaulting to .NET 4.0.

If you double click on the Properties folder in your project and select the Application page, verify that the "Target framework" is set to .NET Framework 3.5.

Or, if you have created a new setup project in Visual Studio 2010, it will have two default settings of .NET 4.0 that must be changed.  I currently change all of my setup projects to use .NET 3.5, as that seems to be nearly universally prevalent now.

To change your setup project framework, expand the Detected Dependencies folder and double click on Microsoft .NET Framework.  In the Properties window, change the Version to .NET Framework 3.5.

Next, right click on the Setup project and select Properties.  Click on the Prerequisites button.  Uncheck .NET Framework 4 and check .NET Framework 3.5 SP1.

Took me a while to find both of those settings, as they were not at all obvious.

After making those changes, all of my setups run fine on workstations and servers without requiring .NET 4.0.

Let me know if that helps, or if you are running into a .NET 4 dependency problem in some other context.


Thanks,

Steve Endow
Dynamics GP Certified Trainer
Dynamics GP Certified IT Professional
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rwheeler23Author Commented:
Thanks Steve that was it. Andrew Dean also saw my question and we chatted about PostMaster. Apparently that is being compliled for GP 2010 using the older dlls and it works. I suggested trying the newer dlls just for future compatiblity.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Dynamics

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.