Getting "all the citrix xml services configured failed to respond to this xml service transaction" error on XenApp 6.0 with Web Interface 5.4.

Thanks in advance for the assistance...

I'm getting "all the citrix xml services configured failed to respond to this xml service transaction" Event ID 31003 error on XenApp 6.0 with Web Interface 5.4.  I uninstalled the web interface from 5.4 to 5.3 per a client request.  Then he asked that I go back to 5.4.  Of course that wreaked havoc and broke something.  I'm no IIS or Citrix expert, but I can defend myself.  LOL  However I can't figure this one out.  I'm running both on the same box using port 8080.  I've researched the heck out of this and found many articles but can't get my issue solved.  This seems to be common out there.  I do not have the option of squashing the sever and rebuilding.

- Windows 2008R2 64BIT Virtual Machine
- XenApp 6.0
- Web Interface 5.4

Any suggestions would be appreciated.  Thanks.
copioAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sekar ChinnakannuStaff EngineerCommented:
Try to apply this hotifx http://support.citrix.com/article/CTX130236 and give a try. Check this citrix article too http://support.citrix.com/article/CTX123418
basrajCommented:
1. Install all the recommended hotfix for Xenapp6:

http://support.citrix.com/article/CTX129229

2. If still the same problem, then dedicate a special port number for XML service other than 80 if shared. ctxxml command used to register or de-register port.

3. Check IMA service is responding on the Broker server and Citrix server.

Run qfarm /load. It should not show 27000 (license error), 10000 (full load) and 0 for no load.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Sekar ChinnakannuStaff EngineerCommented:
Citrix released rollup pack 1 with most of the hotfixes http://support.citrix.com/article/CTX130473
CoralonCommented:
Just a quick note:

The command is
ctxxmlss

Open in new window

to reregister the XML port - you want to register it to a different port, and then back to the port you are using.

qfarm /load will show 20000 for a licensing error, and 10000 as full.

Coralon
copioAuthor Commented:
I found the issue.  I had already run the ctxxmlss command to register to port 8080.  However it was still pointing to the wrong port in the policy.  Someone assisted me and removed the policy that was setting XML on the farm.  I appreciate everyone's help here.  I will distribute the points as best I can for the effort.  I also received some good information from all of you that can be useful in the future.  Thanks!  Happy Holidays.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.