windows 7 won't hibernate

I have windows 7 professional service pack1  HP Elitebook 8540w and my laptop won't hibernate. As soon as I click hibernate, I see if the laptop is going to hibernate mode but I see the login screen in few seconds instead. I have tried different things on different forums like disable network adapters and taking out any wireless mouse or keyboards etc but it won't make any difference. I have rebooted my system and when i typed  powercfg -lastwake, i get this, Wake History Count - 0. Also when I type
powercfg -devicequery wake_armed
I get no output. Any ideas
thanks
mmalik15Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hamid Reza MolahadiCommented:
Use this command: shutdown.exe /h
0
X_layerCommented:
Look here -> LINK.
Really useful stuff to trace various problems.
0
mmalik15Author Commented:
i have jus tried shutdown.exe /h and it brings me back to the login screen
0
Hamid Reza MolahadiCommented:
Here's the thing:
Open cmd and then type: " powercfg -devicequery wake_armed "
a list of the configured devices to wake the computer will be received. Now if your list contains mouse or keyboard then it's ok but if it's contains NIC or something else you should disabled it, to disable items type: " Powercfg -devicedisablewake DEVICENAME "
DEVICENAME  is a device name listed as a result of running the first command.
For example, if the network card "Broadcom NetXtreme Gigabit Ethernet" is listed, we can type this command to disable it:
Powercfg -devicedisablewake "Broadcom NetXtreme Gigabit Ethernet"
After that, reboot the machine and then try again.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.