How to fix iis 6 http error 401.1

I publish web site Asp.net it works fine when i configure it on Integrated windows Authentication, but when i publish it on Digest Authentication for windows domain servers it returns Http error 401.1 - Unauthorized: Access is denied due to invalid credentials.
mostabdoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mostabdoAuthor Commented:
please note that when i cecked the basic authentication (password is sent in clear text) option the web site is working fine
it fails only when i used the digest authentication
reference to the article posted the setspn.exe -S switch returned the following
Usage: setspn.exe [switches data] computername
  Where "computername" can be the name or domain\name

is there -S switch in setspn.exe
0
AmmarRCommented:
hi

are you storing the website in the inetpub folder where anonymous users have access or are you storing it in a different folder in your machine and made a virtual site point to it.

if you did the second option make sure anonymous users have access to the folder..
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

mostabdoAuthor Commented:
The website in the inetpub folder where anonymous users have access.
0
Paul MacDonaldDirector, Information SystemsCommented:
I'm unsure how well these match your problem, but they should be worth looking at:
http://support.microsoft.com/kb/977073
http://forums.asp.net/t/1655919.aspx/1
0
mostabdoAuthor Commented:
the problem was fixed after installing .Net Frame work 2.0 & .Net Framework 3.0 & .Net Framework 3.5 with .Net Framework 4.0
the IIS Default web site is set to  .Net Frame work 2.0
my web site  is set to .Net Frame work 4.0
now the digest authentication works
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mostabdoAuthor Commented:
all the solutions provided was what i have found already while searhing about the error.
so i was expected to have more discussion with the experts in order to find out a solution than provide me with google search results
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.