Remote Desktop troubles

A customer just opened a second satellite office - which for us is the second satellite site. At this and the earlier satellite site we installed a server 2008 r2 to be  a Domain Controller, DNS, File server and Terminal server gateway. Each site also has two servers running 2003 r2 required for a third party application. We brought the newest site up last week.  I know that before I left, I logged onto the DC locally and verified that I was able to remote to the other 2 servers. We get home, remote to the new site but can't remote from the DC/TSG to either of the other 2 servers. We get the standard:
1) Remote access to the server is not enabled
2) The remote computer is turned off
3) The remote computer is not available on the network

However, I can log onto the terminal server gateways at either of the established sites and remote from there to the 2 server 2003s at the new site - disproving all 3 of the possible errors listing above.
 And once in either of those servers, I can remote to the DC. From each of the 3 servers at the new site I can ping the other 2 by IP address and domain name. And finally, from the DC/TSG at the new site, I can remote desktop to the TSG at the main site (didn't bother testing any other connections).

Any suggestions?
LVL 2
YMartinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MarkieSCommented:
I would compare the membership of the "RemoteDesktopUsers" group on your Win2k3 boxes at the new site and at your existing site.

When you are "at home", are you connectiing with the same credentials as you did when you were local, or are you now being classed as a remote user?

cheers
MarkieS
0
YMartinAuthor Commented:
MarkieS,
I'm logging in everywhere as "administrator" all of the time. The "administrator" account should have access by default.
0
YMartinAuthor Commented:
We brought up a 3rd site a few weeks ago and the same thing happened. After a little experimentation I found that I could Remote Desktop to the other servers by using their IP addresses. I double checked DNS and verified that I could ping the servers using IP address and name. Didn't make sense so I tried RDP using the server's name and got the same error. Frustrated, I just tried to connect again and it worked the second time (but only if attempted immediately after closing the error message). Found this to work for both servers at both sites.
Is it Einstein's definition of stupid - Doing the exact same thing twice and expecting different results? This time I found acting stupid worked.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
YMartinAuthor Commented:
Sorry, this one turned out to be a no brainer.
0
MarkieSCommented:
It sounds similar to the universal law of ambiguity!  If you dont understand it just learn to accept it!

Nice to hear it's working...

cheers
MarkieS
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.