xerox workcentre3210 bsod

Hi
I have installed a xerox workcentre 3210 multi-function printer for a dental practice.
Some prints work, but summary reports invariably crash with 0x50. The machine is a sony vaio with win7 home. The xerox driver is correctly win 7 x64
Another xp-pro machine in the practice with the 32 bit xerox driver works correctly.
I have downloaded the latest 64bit win7 driver from xerox (dated 04-16-2010)
The xerox site advises firmware version 2.50.0.95, but the printer has 2.50.00.99
The connection is by tcpip - I noted on the webpage for the printer
s/n 3244088235
os: 2.50.00.99
net: v4.00.95
IPcore 6.6.3.P
engine 1.00.12
The dental software provider blames the print driver, while the supplier blames the dental software.  
peter_lawrieAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

John GriffithConsultantCommented:
Bugcheck 0x50 = invalid memory referenced

You do in fact have the most recent Xerox drivers - http://www.support.xerox.com/support/workcentre-3210-3220/downloads/enus.html?operatingSystem=win7x64

Please upload/ attach the BSOD dump file(s) - c:\windows\minidump
0
peter_lawrieAuthor Commented:
Hi
Here is af minidump. It only happens with this one report, but happens every time. It worked fine with the previous HP printer and works correctly from an XP box to this printer. 111111-19203-01.dmp 111111-19203-01.dmp
0
peter_lawrieAuthor Commented:
I have been contacted by Xerox support who say the problem is nothing to do with the printer, but is a known windows 7 issue which has been raised by other customers. I have contacted the application software developer to see if they use a specific software call in the failing report which is not used in other reports which work correctly. (I am sure they will deny responsibility and point at database development software. Xerox suggested I contact Sony for resolution.
Peter
0
Exploring SharePoint 2016

Explore SharePoint 2016, the web-based, collaborative platform that integrates with Microsoft Office to provide intranets, secure document management, and collaboration so you can develop your online and offline capabilities.

John GriffithConsultantCommented:
Hi Peter -
See if updating Intel Ethernet driver helps.  It pre-dated Windows 7 RTM -
e1y62x64.sys                Fri Jun 12 21:16:42 2009 (4A32FDFA)
http://sysnative.com/drivers/driver.php?id=e1y62x64.sys

".....(I am sure they will deny responsibility and point at database development software. Xerox suggested I contact Sony for resolution. ...."

I agree with you.  Sony will tell you noting is wrong, either and tell you to contact the others.  The never ending circle of blame.

This is not a bible by any means, but Microsoft lists it as compatable - http://www.microsoft.com/windows/compatibility/windows-7/en-us/Search.aspx?l=en-us&type=Hardware&s=xerox%20WorkCentre%203210/3220

Regards,
jcgriff2 MVP
0
peter_lawrieAuthor Commented:
I have been in touch with Xerox support who deny it is their problem. They said it was a known problem with win7 but nothing to do with them. They said Contact Sony, who also denied it was their problem. The dental software supplier also denied responsibility. Clearly, the application is making a call for a specific print which fails with an 0x50 on win32k.sys. It does not happen with XP, nor did it happen with the previous HP printer. The business manager is somewhat prickly so it is awkward going in to fiddle around, especially as they are trying to process patients at the same time.
I agree that the printer is win7 compatible. I checked that before I recommended it.
I have not been able to go in to check the ethernet driver yet. I'd be surprised if that is the issue. The machine is only a few months old and win7 is fully up to date. The issue only occurs with a specific print. In every other respect it is working correctly over the network
0
John GriffithConsultantCommented:
I mentioned the Ethernet driver because -
"..Some prints work, but summary reports invariably crash with 0x50..... The connection is by tcpip..."

Also, the driver pre-dates Windows 7 RTM -- http://sysnative.com/0x1/Windows_OS_Driver_Base_Timestamps.html

My thinking is that the summary report likely results in more info being transmitted to the printer and the June 2009 Vista-SP2 era Ethernet driver may not be communicating properly with the 2010/11 Windows 7 SP1 OS-related drivers like tcpip.sys, netio.sys, etc... (just a theory)

Bugcheck 0x50 = invalid memory referenced.  win32k.sys = Microsoft win32 subsystem (OS-related) driver and is simply a default here.  Usually, 0x50 + win32k.sys  point to video or RAM - but so far, I see no indication of this.

Please Speccy - http://www.filehippo.com/download_speccy
- "File" | "Publish Snapshot" | Paste URL into your next post

Driver Verifier may be of help here.  If a 3rd party driver is the cause, Driver Verifier will flag it and force a BSOD.  Let it run in the background and use the system normally; run the summary report.

http://sysnative.com/0x1/Driver_Verifier.htm

What is the exact model number of the Sony?  Does Sony Support have an updated Ethernet driver?

http://esupport.sony.com/US/perl/select-system.pl?NOPROD=YES&DIRECTOR=DRIVER&mdl=ENTERMODELNUMBER&1=3
0
peter_lawrieAuthor Commented:
Fi
Sorry about the delay - don't close the thread yet. It's a busy practice and it's difficult to get time on the reception machine to resolve the issue.
I had to visit today to remove a trojan from one of the machines. While there I installed the Xerox 3210 printer on one of the win 7 laptops. It crashed on exactly the same report as the reception PC.
I don't have the exact Sony models, but today's machine is a Sony laptop, while the Reception PC is an all in one. Both with Win 7 home. It only crashes on one report. I spoke to the dental software support line. The developers are no longer with them. Software uses a db, but I don't have info on which. It is obviously one procedure call at fault, as no other prints cause crash.
Basicaly Xerox support say it's not their problem. Sony deny it's them, so I am left with the obvious win7 driver bug.
If I am able to get some time there during the holiday,. I will try your suggestions.
Best regards
Peter Lawrie
0
peter_lawrieAuthor Commented:
Please don't close yet. The customer has a work=round, but I need to visit to apply earlier suggestions. She has other priorities at the moment. I do value the suggestions made and will implement them when the opportunity arises.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
peter_lawrieAuthor Commented:
Hi
Sorry to mess you around. I have not yet been invited back into the practice to apply your suggestions. The work-around of using the XP PC produces the report they want. Rather than wait any longer, I'll close the question and award points. I think the issue is actually connected to a procedure call in  the dental software which works in XP but not seven. Although it worked in seven to the HP inkjet MF printer, but not to the Xerox MF. For every other use of the printer, there does not seem to be a problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.