SBS2003 R2 only half of the email accounts can get email to phones

we have a sbs2003 R2 server and 6 users have cell phones that get email. Of the 6, 3 cannot get email, it just stopped working a few days ago. I re-ran internet connection wiz restarted all services, rebooted the firewall no change. why would some work and other stop working?
here is the phone type and carrier and status.
Phone                         Carrier       Email
Blackberry Torch      AT&T      Yes
Iphone 4 @ 3g      AT&T      No
Blackberry                         Tmobile      Yes
Blackberry                         Tmobile      Yes
Samsung Galaxy S          Tmobile      No
Iphone 4 @ 4g      AT&T      No

Any thoughts on what to check next?
mspencer100Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NetfloCommented:
Hi,

I would check on the following website for any problems with the affected users. It looks to me you have a certificate issue, which the BB users will possibly soon experience too as they are connected via the service providers BIS connection.

I would recommend running the default 'Exchange ActiveSync' test... https://www.testexchangeconnectivity.com/

This will point you into the next direction on what is wrong with your remote mobile devices.

Just to cover the basics, I would also recommend running the SBS BPA: http://www.microsoft.com/download/en/details.aspx?id=5334 and also the Exchange 2003 BPA: http://www.microsoft.com/download/en/details.aspx?id=22485 as this will highlight any inconsistencies with your server configuration.

If you have any questions on this, please post back here.
Thanks and best of luck!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mspencer100Author Commented:
i got an update when the user has outlook webaccess open on their desktops then they get email to thier phone email client. Why would this would matter? doesnt the phone synce with Exchange and not the desktop?
0
NetfloCommented:
I have a feeling that your ActiveSync users (iPhone and Android) are connected on the internal wireless and interally cant resolve your OWA address, hence the failure. Where as your BB users go via BIS. Do you want to ask the iPhone or Android users to turn off their wireless but leave data on and check?

Having OWA open on the desktop is not linked and yes the phone would operate independently.

Have you gone through my previous post, what are the results. No point really trying to solve 1 problem if your server is not configured or updated properly, as you're just going around in circles.

On the to do list...

1. Action items in the first post and report back
2. Check if emails work if the WLAN is off and data is on
0
NetfloCommented:
*internally
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.