Disable Windows Time Default Update on Startup

We have an application that is required to run on (GTM) Casablanca, Monrovia time zone but set to our local time which is (GTM-06:00) Central Time.

Our issue is we are running these servers on VMware, by default windows will update with the 1st NTP server it can see on boot up to validate time. This creates an issue because it will set the time 6 hours ahead to Monrovia time zone. We opened a ticket with VMware as this issue happens when we run VDR, snapshots or do a reboot. To them this is a default of windows and will use the time on the host even though the box is not checked in the tools to sync with the host, and then sync with the time server listed after.

I am looking for a way to possibly disable this in the registry, as we have disable the NTP service and GPO settings which had no effect because this is something that is happening on boot up.

I am open to any and all suggestions, changing the time zone to match is not an options so anything out side of that. :)
LVL 4
rm-entAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pete LongTechnical ConsultantCommented:
Assuming you have removed the tickbox in the VMware guest OS to sync time with the host (Open VMware tools)

>>changing the time zone to match is not an options so anything out side of that

The server alters its time from UST to its locale time zone, so unless you change that it will always reset itself to the correct time in the timezone you have placed it in.
Be aware even if you got this to work, two active directory windows servers in the same domai with clocks more than 10 minutes apart cant talk to each other :(
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CGretskiCommented:
Time zones are just a display change, computers all work internally with GMT.
NTP is the same, it will syncronise computer clocks to the same time GMT.  Your timezone just adds/subtracts from the time displayed.
If your servers are in a domain then clocks must match otherwise kerberos authentication fails.

The only part of windows which will sync time is the "windows time" service, if you've already disabled that on the VM then it must be VMWare updating the clock - though this is normally a neccessity as the VMs have no hardware clock so without it every VM would boot up showing the same time as when they were shut down.

What does your application need to run in a fake time for?  Are you running reports that need pre/post-dating? if so you may need to edit the report to add/subtract time.
0
rm-entAuthor Commented:
The servers are all on the same time zone this is a self contained environment so to speak. So all domain controllers, and applications servers have the same time zone and time setup.

The application needs that time zone because it does not have daylight savings, I know I can disable update daylight savings automatically but we have tried to go to our timezone and caused some issues.

This is a games application so it is very time sensitive as all the gaming devices have to be in sync with one another, and for accurate daily reporting.

VMware gives windows some defaults on boot up, one of the defaults is a time check according to VMware and the code they send. So they are not doing anything except pre-loading the defaults for windows. They expressed that they have no way to change this and wouldn't as it is there default with all OS, i did a test with Cent OS and have the same issue...
0
Acronis Data Cloud 7.8 Enhances Cyber Protection

A closer look at five essential enhancements that benefit end-users and help MSPs take their cloud data protection business further.

rm-entAuthor Commented:

PeteLong
Can you go into more details about what you said above, how would I alter this?

"The server alters its time from UST to its locale time zone, so unless you change that it will always reset itself to the correct time in the timezone you have placed it in."
0
rm-entAuthor Commented:
we went ahead and uninstalled the vmware tools and that fixes this as the server has no communication to the host now.

thanks for the thoughts though.
0
rm-entAuthor Commented:
we went ahead and uninstalled the vmware tools and that fixes this as the server has no communication to the host now.

thanks for the thoughts though.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.